Re: question about patching MSDE 2000

From: Luca Pugliese (luca.pugliese@cryptonet.it)
Date: 07/30/02


From: "Luca Pugliese" <luca.pugliese@cryptonet.it>
Date: Tue, 30 Jul 2002 01:32:26 -0700


I just read your message,
any help is welcome,
thank you,

Luca Pugliese

>-----Original Message-----
>Luca, I am in the process of reproing this and will get
>back to you very soon on a possible workaround if and
when
>we nail down the problem.
>
>thx...
>
>This posting is provided "AS IS" with no warranties, and
>confers no rights.
>
>>-----Original Message-----
>>This looks more complicated than something we can do
>through the newsgroup
>>based on having our setup team take a quick pass at it.
>Please call product
>>support and get a case started with them....
>>
>>--
>>Richard Waymire, MCSE, MCDBA
>>
>>This posting is provided "AS IS" with no warranties, and
>confers no rights.
>>"Luca Pugliese" <luca_pugliese@virgilio.it> wrote in
>message
>>news:16dee01c22d8c$fca57b50$9ee62ecf@tkmsftngxa05...
>>you' find it in select_version.txt. I also enclose the
log
>>of the installation of MSDE on the D: drive and the log I
>>get when I try to patch default instances of MSDE
>>installed on C: and D:
>>
>>Thank you,
>>
>>--
>>Luca Pugliese
>>
>>>-----Original Message-----
>>>Great, can you post the version number reported by
select
>>@@version?
>>>
>>>--
>>>Richard Waymire, MCSE, MCDBA
>>>
>>>This posting is provided "AS IS" with no warranties, and
>>confers no rights.
>>>"Luca Pugliese" <luca_pugliese@virgilio.it> wrote in
>>message
>>>news:1932001c22c99$49869390$3bef2ecf@TKMSFTNGXA10...
>>>>
>>>> >-----Original Message-----
>>>> >So it's a named instance? Are you applying the
patch
>>to
>>>> a named instance?
>>>>
>>>> No, it's not a named istance. As I said clearly, it's
>>just
>>>> a default istance installed on a drive different than
>>C:.
>>>> To install a named istance MS documentation says to
add
>>to
>>>> the setup.ini the line 'INSTANCENAME="MyInstance"'
and
>I
>>>> didn't do it.
>>>>
>>>> >There's a specific note in the sp2 readme.txt for the
>>>> MSDE download that
>>>> >when you get that error you need to order a CD from
>>>> Microsoft in order to
>>>> >apply the service pack.
>>>> >
>>>>
>>>> I assure you that I read the readme.txt thoroughly,
but
>>it
>>>> tells that you have to order the CD only if you
>>installed
>>>> MSDE 2000 using a file different than sqlrun01.msi
and
>I
>>>> saw in the registry that I used sqlrun01.msi to
install
>>>> it.
>>>>
>>>> >Also, how did you verify that the patch was/was not
>>>> applied?
>>>> >
>>>> >In this case you should log in to MSDE with osql.exe
>>and
>>>> run "select
>>>> >@@version" to check the version number.
>>>> >
>>>>
>>>> As I said, I read the documentation thoroughly, and I
>>>> verified the version just like you said with
osql.exe,
>>>> like explained in the readme file.
>>>>
>>>> Thank you,
>>>>
>>>> --
>>>> Luca Pugliese
>>>>
>>>>
>>>> >--
>>>> >Richard Waymire, MCSE, MCDBA
>>>> >
>>>> >This posting is provided "AS IS" with no warranties,
>>and
>>>> confers no rights.
>>>> >"Luca Pugliese" <luca_pugliese@virgilio.it> wrote in
>>>> message
>>>> >news:18cff01c22bed$ffd507f0$3bef2ecf@TKMSFTNGXA10...
>>>> >> hi,
>>>> >>
>>>> >> I'm trying to solve a problem for a customer and
any
>>>> help
>>>> >> would be welcome.
>>>> >> I'm using the version of MSDE 2000, which was
>bundled
>>>> with
>>>> >> ISS RealSecure.
>>>> >> I'm trying to patch it using SQL SP2 (the filename
>of
>>>> the
>>>> >> patch is ql2kdesksp2.exe), but although the
>>installation
>>>> >> of the patch seems to succeed, when I verify the
>>version
>>>> >> number of sql, I can't see any difference with the
>>>> number
>>>> >> I got before applying the patch.
>>>> >>
>>>> >> I don't know if the command I'm using is correct or
>>if
>>>> >> something is missing because documentation on the
>>>> subject
>>>> >> is quite complex and difficult to read.
>>>> >>
>>>> >> First time I tried to app{wj"Lk4 Pk
ly
>the patch, I simply ran
>>the
>>>> >> setup but I got an error saying:
>>>> >>
>>>> >> "This installation package could not be opened.
>>Verify
>>>> >> that the package exists and that you can access it,
>>or
>>>> >> contact the application vendor to verify that this
>>is a
>>>> >> valid Wi
>.
>