Re: IIS IWA with IE started via smart card credentials.



On Sep 10, 8:53 am, ceh <cehup...@xxxxxxxxx> wrote:
IIS 6 on Win 2k3
IE 6+ on XP Pro SP2

Hi, I'm starting a IE as the user on a smart card via
createprocesswithlogonw to attempt Integrated Windows Authentication
to a website.

The userid is the string version of the cert, the passwd is the PIN
and there is no domain.
IE starts fine.  TaskMgr shows it running as the correct user.
I then navigate to an IWA web site.  IE prompts me for credentials.
I've tried setting IE to automatically logon or logon with un and pw
via options in multiple sites.  None alleviate the issue.

If I start IE with runas via un / pw it can IWA me just fine.

Can anyone tell me what I need to do to get the smard card credential
invocation to work correctly?

Thanks.

Sorry, forgot to mention that if I log on to the OS via smart card and
then navigate to that site, IWA works fine. IIS gets the info it
needs.

The problem is only when the OS logged on user and the user running IE
are different.
.



Relevant Pages

  • IWA with IE started via smart card credentials
    ... TaskMgr shows it running as the correct user. ... I've tried setting IE to automatically logon or logon with un and pw ... If I start IE with runas via un / pw it can IWA me just fine. ... If I logon to OS with smart card and run IE as that OS logged on user ...
    (microsoft.public.sharepoint.portalserver)
  • IIS IWA with IE started via smart card credentials
    ... I then navigate to an IWA web site. ... I've tried setting IE to automatically logon or logon with un and pw ... If I start IE with runas via un / pw it can IWA me just fine. ... If I logon to OS with smart card and run IE as that OS logged on user ...
    (microsoft.public.inetserver.iis.security)
  • IIS IWA with IE started via smart card credentials.
    ... I'm starting a IE as the user on a smart card via ... TaskMgr shows it running as the correct user. ... I then navigate to an IWA web site. ... I've tried setting IE to automatically logon or logon with un and pw ...
    (microsoft.public.platformsdk.security)