Re: Integrated Windows authentiation does not working



Your solution suggests that you configured something to cause that behavior
but you don't know what. IIS is simply behaving as configured. Seems hard to
fault it as "something inside of IIS"...

--
//David
IIS
http://blogs.msdn.com/David.Wang
This posting is provided "AS IS" with no warranties, and confers no rights.
//

"WiZARD" <WiZARD@xxxxxxxxxxxxxxxxxxxxxxxxx> wrote in message
news:C0486A9B-7880-40AE-A81C-EE5733CFB7C2@xxxxxxxxxxxxxxxx
I mean what I still got same problem IIS noes not recognized
authentication.

But I found a solution:
1. Remove a virtual directory from IIS
2. Remove a link from IIS.
3. Setup a new virtual directory.

Just reinstall a project in IIS.

Seems what was somthing inside of IIS. But what? It's a secret sealed with
seven seals. Developers who work under project propose reinstall OS. I
believe, what need just a think.

I'm not a developer, I'm just a QA Engineer. :)
anyway, Thanks!

Sorry for my poor English.


"David Wang [Msft]" wrote:

Without knowing what "does not helps" means, it is impossible to continue
troubleshooting.

You stated that you want Integrated authentication to be effective for
.Net
applications. Debugging shows you that requests are using anonymous user.
You seem to expect some other result (what other result?)

I said to turn off anonymous authentication so that browser must
authenticate using configured protocol in IIS (presumably Integrated
Authentication). Now what happened?

Also realize that by default, ASP.Net runs as process identity and not
Impersonated Identity obtained through authentication. So you need to
tell
ASP.Net to remain impersonated to have the user identity obtained through
IIS authentication to take effect. This may/not be what you are asking
for.

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnbda/html/authaspdotnet.asp

--
//David
IIS
http://blogs.msdn.com/David.Wang
This posting is provided "AS IS" with no warranties, and confers no
rights.
//



.



Relevant Pages

  • Re: HELP PLEASE The request failed with HTTP status 401: Access Denied.
    ... Web Security: Part 2: Introducing the Web Application Manager, Client ... Authentication Options, and Process Isolation ... It introduces the Web Application Manager in IIS that ... logon session, which is dangerous. ...
    (microsoft.public.dotnet.framework.aspnet.security)
  • RE: Can no longer access ActiveSync
    ... OMA and Exchange/Exchange-OMA virtual directory. ... Please verify Authentication settings by the following steps. ... Open IIS Manager ... issue may be caused by the Exchange attribute of original user account. ...
    (microsoft.public.exchange.admin)
  • Re: Basic Authentication fails with Error 401.2 where Integrated s
    ... I didn't realise the Web Sites folder in IIS manager threw up a global ... sure that Basic Authentication is allowed to function on your server. ... ACCOUNTNAME, this is the account that I am trying to grant access to: ... Account: COMPUTERNAME\ACCOUNTNAME Access type: FULL ...
    (microsoft.public.inetserver.iis.security)
  • Re: SBS2k3 and activesync over the air
    ... the Exchweb virtual directory. ... ONLY 'Basic authentication' is selected ... please restart your IIS service and test your issue again. ... Regarding ActiveSync issue, support code 0x85010014 means error HTTP 500. ...
    (microsoft.public.windows.server.sbs)
  • Re: SharePoint password prompting
    ... Sharepoint has nothing to do with IIS -- it is a separate product built ... Default configuration uses Integrated authentication and should work that ... authentication, and digest authentication. ...
    (microsoft.public.inetserver.iis.security)