Re: IIS6 Application Pool - Unspecified Error / Service Unavailable

From: Colin Bowern (colinbowern_at_nospam.indimensions.com)
Date: 12/29/04


Date: Wed, 29 Dec 2004 08:49:05 -0500

I seem to have resolved the issue by recreating the application pool account
(delete / recreate). Still not sure of the root cause.

"Colin Bowern" <colinbowern@nospam.indimensions.com> wrote in message
news:%23vjUQka7EHA.2552@TK2MSFTNGP09.phx.gbl...
> Can't seen to figure out why the server is returning Service Unavailable
> to the web browser and Unspecified Error for the application pool. It is
> using a domain user account (member of IIS_WPG, temporarily added to
> Domain Admins / Administrators) and IIS is running on a domain controller.
> My event log is outputting three errors in the system log:
>
> ---
> Event Type: Warning
> Event Source: W3SVC
> Event Category: None
> Event ID: 1021
> Date: 12/29/2004
> Time: 8:14:18 AM
> User: N/A
> Computer: MYCOMPUTER
> Description:
> The identity of application pool, 'Test Pool' is invalid. If it remains
> invalid when the first request for the application pool is processed, the
> application pool will be disabled. The data field contains the error
> number.
>
> For more information, see Help and Support Center at
> http://go.microsoft.com/fwlink/events.asp.
> Data:
> 0000: 80070569
>
> Event Type: Warning
> Event Source: W3SVC
> Event Category: None
> Event ID: 1057
> Date: 12/29/2004
> Time: 8:16:52 AM
> User: N/A
> Computer: MYCOMPUTER
> Description:
> The identity of application pool 'Test Pool' is invalid, so the World Wide
> Web Publishing Service can not create a worker process to serve the
> application pool. Therefore, the application pool has been disabled.
>
> For more information, see Help and Support Center at
> http://go.microsoft.com/fwlink/events.asp.
>
> Event Type: Error
> Event Source: W3SVC
> Event Category: None
> Event ID: 1059
> Date: 12/29/2004
> Time: 8:16:52 AM
> User: N/A
> Computer: MYCOMPUTER
> Description:
> A failure was encountered while launching the process serving application
> pool 'Test Pool'. The application pool has been disabled.
>
> For more information, see Help and Support Center at
> http://go.microsoft.com/fwlink/events.asp.
> ---
>
> The event log and error messages seem rather vague and silly in my
> opinion. I have been through KB article 812614, REGMON, FILEMON, and other
> tools with no luck. Any thoughts?
>
> Thanks!
> Colin
>