Re: IIS 5.0 can't handle multiple request at the same time with the same Web site(Application)?

From: PL (pblse2_at_yahoo.se)
Date: 11/22/03


Date: Sat, 22 Nov 2003 12:02:22 +0100


What machine ? If you have single cpu there is no way any webserver
can handle two requests at the exact same time.

And, what makes you think you were able to request at the exact same time ?
You need a stress test application for that, you cant just open two webbrowsers
and imagine that you are fast enough to make two simulataneous requests.

Also, you can hardly get accurate timings with using Now, it only goes
down to seconds.

It's your testing that is in fault here, and nothing else.

PL.

"Rayman" <ray.man@scfulfil.com> skrev i meddelandet news:OYnQlSKsDHA.540@tk2msftngp13.phx.gbl...
Dear All,

I am currently using Windows 2000 SP 4 with IIS 5.0.
I found that IIS 5.0 can't handle multiple request at the same time
with the same Web site(Application), here is the code for testing:

-----------------------Begin--------------------
<%
response.write "Start Time : " & now() %> <br> <%
For x = 1 to 100000000
    'Do nothing
next
response.write "End Time : " & now() %> <br> <%
%>
-------------------------End---------------------

The above code was included in one asp page Test.asp and two user run with the following result:

--------------------------------------------------------------
User 1
Submit Time : 11/22/2003 10:45:50 AM
ASP Start Time : 11/22/2003 10:45:50 AM
ASP End Time : 11/22/2003 10:46:25 AM

User 2
Submit Time : 11/22/2003 10:45:52 AM
ASP Start Time : 11/22/2003 10:46:25 AM
ASP End Time : 11/22/2003 10:46:58 AM
--------------------------------------------------------------

So, the result show that IIS can't handle two different request at the same time, instead, the second
user will wait the first user completed the process! I have tried to change the Application Protection
setting, but the problem still happened. I have read some article which said that IIS 6.0 have solved
this problem right? However, IIS 6.0 could only run on Windows Server 2003, so anyone know is there
any solution for IIS 5.0?

Thanks!

Br,
Rayman