401 - Error from WebServer

From: John Maly (jmalyamakkil@comshare.com)
Date: 09/11/02


From: "John Maly" <jmalyamakkil@comshare.com>
Date: Wed, 11 Sep 2002 16:04:22 -0400


Hi All,

Well, here is a sample of the IIS log file which I get on my machine. Just
would like to know if it is ok to get the return code "401"....

Here is what happens: When I open the browser the very first time and try
this " http://juhi/deciweb/test.asp" where "juhi" is my machine name,
deciweb is a virtual folder in which our application is installed. It works
fine, but writes two lines to the IIS log file. One line has the return code
as "401" which I guess is "Unauthorized: Logon Failed due to server
configuration" and the other retun code is 200 which is successful
execution. Subsequent refreshing of the browser without shutting down the
browser, would return only the expected code of "200"....

The "401" shows up only the very first time the browser is opened.

I was wondering if it is ok that "401" gets written to the log file...or is
there anything I have to tweak in the IIS setup, so that it does not write
that line to the log file.

Thank you for your time....
- John
==============================================================
#Software: Microsoft Internet Information Server 4.0
#Version: 1.0
#Date: 2002-09-11 14:47:27
#Fields: time c-ip cs-method cs-uri-stem sc-status
17:31:13 130.211.4.180 GET /deciweb/test.asp 401
17:31:13 130.211.4.180 GET /deciweb/cdweb/images/decisionweb.gif 200
17:31:13 130.211.4.180 GET /deciweb/test.asp 200
17:31:32 130.211.4.180 GET /deciweb/test.asp 200
=============================================================