RE: Config error using domain user for ASP.NET worker process

From: Bassel Tabbara [MS] (basselt@online.microsoft.com)
Date: 01/29/03


From: basselt@online.microsoft.com (Bassel Tabbara [MS])
Date: Wed, 29 Jan 2003 17:36:52 GMT


Michael,
I tried it on my machine with userName="Domainname\username" and
password="mypassword"
and it worked perfectly. Please make sure that you have the correct case on
domain name and the
password. Other than that, try to use just the username without the domain
name. Another option
is to try different casing of the domain name. The direction of the slash
is correct since it worked on my machine.

Please make sure to reset IIS when you save the machine.config. You can
reset it by using the following command prompt: iisreset.

Thanks,
Bassel Tabbara
Microsoft, ASP.NET

This posting is provided "AS IS", with no warranties, and confers no rights.

--------------------
| Content-Class: urn:content-classes:message
| From: "Michael" <mike@shiftinc.com>
| Sender: "Michael" <mike@shiftinc.com>
| References: <08b401c2c796$d5377b00$d5f82ecf@TK2MSFTNGXA12>
<ACdUXP6xCHA.2404@cpmsftngxa08>
| Subject: RE: Config error using domain user for ASP.NET worker process
| Date: Wed, 29 Jan 2003 07:47:45 -0800
| Lines: 132
| Message-ID: <050e01c2c7ad$c47a6360$8af82ecf@TK2MSFTNGXA03>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="iso-8859-1"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
| Thread-Index: AcLHrcR62fIjJqxLR+WBu2QMaHdmDw==
| Newsgroups: microsoft.public.dotnet.framework.aspnet.security
| NNTP-Posting-Host: TK2MSFTNGXA03 10.40.1.48
| Path: cpmsftngxa06!cpmsftngxa08
| Xref: cpmsftngxa06 microsoft.public.dotnet.framework.aspnet.security:3807
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.security
|
| Bassel,
|
| Here is the error that is dumped, there is no stack
| trace.
|
| Mike
|
|
|
| Configuration Error
| Description: An error occurred during the processing of a
| configuration file required to service this request.
| Please review the specific error details below and modify
| your configuration file appropriately.
|
| Parser Error Message: An error occured while parsing
| EntityName. Line 353, position 277.
|
| Source Error:
|
|
| Line 351: worker process for the desired
| application
| Line 352: -->
| Line 353: <processModel enable="true"
| timeout="Infinite" idleTimeout="Infinite"
| shutdownTimeout="0:00:05" requestLimit="Infinite"
| requestQueueLimit="5000" restartQueueLimit="10"
| memoryLimit="60" webGarden="false" cpuMask="0xffffffff"
| userName="DEV\NETGlobalUser" password="MyPassword"
| logLevel="Errors" clientConnectedCheck="0:00:05"
| comAuthenticationLevel="Connect"
| comImpersonationLevel="Impersonate"
| responseRestartDeadlockInterval="Infinite"
| responseDeadlockInterval="Infinite" maxWorkerThreads="25"
| maxIoThreads="25"/>
| Line 354:
| Line 355: <webControls
| clientScriptsLocation="/aspnet_client/{0}/{1}/"/>
|
|
| Source File: c:\winnt\microsoft.net\framework\v1.0.3705
| \Config\machine.config Line: 353
|
|
| ----------------------------------------------------------
| ----------------------
| Version Information: Microsoft .NET Framework
| Version:1.0.3705.288; ASP.NET
|
|
|
| >-----Original Message-----
| >Michael,
| >Please can you post the error message with the stack
| trace?
| >
| >Thanks,
| >Bassel Tabbara
| >Microsoft, ASP.NET
| >
| >This posting is provided "AS IS", with no warranties,
| and confers no rights.
| >
| >--------------------
| >| Content-Class: urn:content-classes:message
| >| From: "Michael" <mike@shiftinc.com>
| >| Sender: "Michael" <mike@shiftinc.com>
| >| Subject: Config error using domain user for ASP.NET
| worker process
| >| Date: Wed, 29 Jan 2003 05:03:35 -0800
| >| Lines: 28
| >| Message-ID: <08b401c2c796$d5377b00
| $d5f82ecf@TK2MSFTNGXA12>
| >| MIME-Version: 1.0
| >| Content-Type: text/plain;
| >| charset="iso-8859-1"
| >| Content-Transfer-Encoding: 7bit
| >| X-Newsreader: Microsoft CDO for Windows 2000
| >| X-MimeOLE: Produced By Microsoft MimeOLE
| V5.50.4910.0300
| >| Thread-Index: AcLHltU3TiOSAoMaSaunOcmxZI+uhQ==
| >| Newsgroups:
| microsoft.public.dotnet.framework.aspnet.security
| >| Path: cpmsftngxa06
| >| Xref: cpmsftngxa06
| microsoft.public.dotnet.framework.aspnet.security:3803
| >| NNTP-Posting-Host: TK2MSFTNGXA12 10.40.1.164
| >| X-Tomcat-NG:
| microsoft.public.dotnet.framework.aspnet.security
| >|
| >| I am attempting to configure an Active Directory
| domain
| >| account that will be used for the ASP.NET worker
| process
| >| instead of local MACHINE or SYSTEM. I have followed
| all
| >| of the MSDN articles for creating the user, setting
| all
| >| of the required ACL's on various folders, setting the
| >| local security policy attributes, etc.
| >|
| >| I have modified my Machine.Config's <processModel>
| >| section to include the new user credentials such as:
| >| userName="MyActiveDirectoryDomain\MyUser"
| >| password="MyPassword"
| >|
| >| However, when I hit my site...the .NET runtime throws
| >| a "Configuration Error" and indicates that an error
| >| occurred while parsing EntityName on the
| <processModel>
| >| line. It appears that the .NET runtime can't even
| parse
| >| the config file correctly with the Domain\User
| syntax.
| >| At least a rights issue would have resulted in an
| invalid
| >| username/password error or does not have required
| rights,
| >| etc. It doesn't even get that far...
| >|
| >| I have combed through every white paper, web article,
| >| etc. and can't seem to find anything related to this
| >| specific error or how to solve it...
| >|
| >| Thanks,
| >| Mike
| >|
| >|
| >
| >.
| >
|



Relevant Pages

  • Re: Error with machine.config??
    ... Are you getting this from a browser or in your IDE? ... > When I tried to access my aspx server, I got the config error followed. ... > below and modify your configuration file appropriately. ... > Source Error: ...
    (microsoft.public.dotnet.security)
  • RE: Config error using domain user for ASP.NET worker process
    ... I have located the problem and Microsoft might want to ... My only guess is the ampersand causes the parser to puke ... >Bassel Tabbara ... Config error using domain user for ASP.NET ...
    (microsoft.public.dotnet.framework.aspnet.security)