Re: McAfee and CygWin SSH



Todd H. wrote:
"Nico Kadel-Garcia" <nkadel@xxxxxxxxxxx> writes:

Nico Kadel-Garcia wrote:
I've got a problem: I had CygWin sshd runing fine on Windows XP Home
a week or so ago, then changed my anti-virus to a current version of
McAfee. Suddenly, I can't get it working, and the error messages are
less than informative.Attempts to ssh to localhost, even with the
firewall turned off, are failing.

It's not clear to me that it's McAfee biting me, sinice lots of
references to such problems exist but they vary wildly in their
reported problem and fix. Has anyone been through this lately, and
gotten it actually working?

Well, I got a McAfee technicion in a chat window: he walked me
through shutting down all McAfee services, and I'm still seeing the
problem. It's frustrating: this was working last week.

Does netstat -an | grep LISTEN show anything listening on port 22 (or
whatever)?

Are you running McAfee AV only, or their whole security suite and
firewall?

Yeah, netstat says:

$ netstat -an | grep LISTEN
TCP 0.0.0.0:22 0.0.0.0:0 LISTENING
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
TCP 0.0.0.0:135 0.0.0.0:0 LISTENING

etc. I see something like this when connecting:

$ ssh -v -v localhost
OpenSSH_4.3p2, OpenSSL 0.9.8b 04 May 2006
debug1: Reading configuration data /etc/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: Connection established.
debug1: identity file /home/Nico/.ssh/identity type -1
debug1: identity file /home/Nico/.ssh/id_rsa type -1
debug1: identity file /home/Nico/.ssh/id_dsa type -1
ssh_exchange_identification: read: Software caused connection abort

I'm not seeing anything useful in /var/log/sshd.log, either.


.



Relevant Pages