compile issues on HP-UX 11i 64Bit

From: killahertz (killahertz@world-domination.net)
Date: 01/29/03


From: "killahertz" <killahertz@world-domination.net>
Date: Wed, 29 Jan 2003 16:32:10 +0100

Hi,

Iím getting the following error while compiling the OpenSSL 0.9.7 source on
HP-UX 11i 64Bit with the native HP ANSI/C compiler:

making all in ssl...

cc -I../crypto -I.. -I../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DH
AVE_DLFCN_H -DOPENSSL_NO_KRB5 +DD64 +O3 +Optrs_strongly_typed +Olibcalls -Ae
+ESlit -DB_ENDIAN -DMD32_XARRAY -c s2_meth.c

cc -I../crypto -I.. -I../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DH
AVE_DLFCN_H -DOPENSSL_NO_KRB5 +DD64 +O3 +Optrs_strongly_typed +Olibcalls -Ae
+ESlit -DB_ENDIAN -DMD32_XARRAY -c s2_srvr.c

cc -I../crypto -I.. -I../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DH
AVE_DLFCN_H -DOPENSSL_NO_KRB5 +DD64 +O3 +Optrs_strongly_typed +Olibcalls -Ae
+ESlit -DB_ENDIAN -DMD32_XARRAY -c s2_clnt.c
cc: "1405" terminated abnormally with signal /opt/ansic/lbin/ccom.
*** Error exit code 9
Stop.
gmake: *** [sub_all] Error 1

All other components so far seem to build correctly.

I used the following configure command:

./Configure --prefix=/working/HP-UX/openssl hpux64-parisc2-cc

Is this a bug or am I doing something wrong? I am using GNU make.

Thanks in advance,
AG

--
--
|"The physicist's greatest tool is his wastebasket." - Albert Einstein.
|"When did ignorance become a point of view ? - Scott Adams.
|"The collective IQ of a location is inversely proportional to the number of
people gathered."