Re: Security



Leythos wrote:
You need ALL Windows Updates, Antivirus software, the most current Java,
and I would suggest that you use FireFox, the latest version.

If I choose to not visit any website requiring Java, do I still need
the most current Java?
I've got Firefox now - just need NOD32.
.