Please help with htaccess

From: Leslie E. Zeigler (never_at_dullmoment.com)
Date: 05/22/05


Date: Sun, 22 May 2005 20:25:02 GMT

Hello!

Some time ago, I set up a computer installed with Windows 2000 as a
webserver running Apache2 and had a directory I wished to keep private.
password protected with

.htaccess. It worked with no trouble for the few years I used it but

that was long ago and I only set it up just that once.

Recently, I have been experimenting with Linux and attempting to recreate my
personal webserver. So far, most everything is working correctly. Phpbb2
with SQL Database and

Photo-gallery work nicely.

However, I'm having a lot of trouble getting the .htaccess password
protection to work this time with the one directory that I would like to
keep private.

But first let me say that I've spent many, many days reading through

manuals and all sorts of "online help" already posted by people that have
had the

same or similar problem, but with no luck in my case. So please realize that
I've attempted to solve the problem on my own already. ;-)

Can anyone suggest what I might be missing?

I created the .htpasswd directory with the .htpasswd file as described in
the

many help sites I've visited researching this particular problem, made the
.htaccess file and placed it in the directory I wish to protect and modified
the httpd.config file to include a

"<directory> </directory>" entry for the specific directory I would like to
protect with htaccess.

I get no errors when restarting Apache2 but the directory just keeps loading

with no password prompt no matter what I do in the httpd.conf file. L

Can someone please suggest what I might be doing to keep Apache2 from using

.htaccess correctly?

Thanks in advance you for any help!!

LZ