RE: SHADOW - ssh autologon problem

From: Richard Gilman (Richard.Gilman@ntn.com)
Date: 01/25/02


From: Richard Gilman <Richard.Gilman@ntn.com>
To: "'Jerry A. Shenk'" <jshenk@decommunications.com>, Focus on Intrusion Detection Systems <FOCUS-IDS@securityfocus.com>
Date: Fri, 25 Jan 2002 09:21:02 -0800

Is it possible that you have installed a new version of ssh? I believe the
SHADOW.conf does a `which ssh` to determine which binary to run. Could it be
finding a different version (i.e. ssh1 vs. ssh2) than the one you are
execute at the prompt. The only other thing that comes to mind is that the
user that has the keys setup with the empty passphrase is somehow not the
same user the fetchem.pl is running under.

Rich

-----Original Message-----
From: Jerry A. Shenk [mailto:jshenk@decommunications.com]
Sent: Friday, January 25, 2002 5:32 AM
To: Focus on Intrusion Detection Systems
Subject: SHADOW - ssh autologon problem

I'm having a bit of a problem with a SHADOW installation that's been
running for two years. The problem is that I can't keep from being prompted
for a password when fetchem.pl runs (using the -debug switch and watching
/tmp/fetchem.log). If I try to scp or ssh from the command-line, I'm right
in, without the password prompt.

--------------------------------------------------------------
Jerry A. Shenk - MCNE, CCNA,
GCIA (GIAC Certified Intrusion Analyst)
GCIH (GIAC Certified Intrusion Handler)
Sr. Systems Engineer - Computer Networking Services
D&E Networks, Inc.
jshenk@decommunications.com (also jas@decns.com)
1-877-433-8632 Fax via efax: (253) 323-5149 (new number 6/9/01)

my website: http://jerryslinux.dyndns.org/jas - PGP sig. file on this site