[ MDVSA-2012:039 ] libtasn1



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2012:039
http://www.mandriva.com/security/
_______________________________________________________________________

Package : libtasn1
Date : March 27, 2012
Affected: 2010.1, 2011., Enterprise Server 5.0
_______________________________________________________________________

Problem Description:

A vulnerability has been found and corrected in libtasn1:

The asn1_get_length_der function in decoding.c in GNU Libtasn1 before
2.12, as used in GnuTLS before 3.0.16 and other products, does not
properly handle certain large length values, which allows remote
attackers to cause a denial of service (heap memory corruption and
application crash) or possibly have unspecified other impact via a
crafted ASN.1 structure (CVE-2012-1569).

The updated packages have been patched to correct this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1569
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2010.1:
266b582ab44051653aad74cacef55741 2010.1/i586/libtasn1_3-2.6-2.1mdv2010.2.i586.rpm
4a6be65d84839edc27f239ab515cf178 2010.1/i586/libtasn1-devel-2.6-2.1mdv2010.2.i586.rpm
4047210a75f4a602d0aa29a727ed93f6 2010.1/i586/libtasn1-tools-2.6-2.1mdv2010.2.i586.rpm
80d708b77aacdd9b9df4ff47005e7808 2010.1/SRPMS/libtasn1-2.6-2.1mdv2010.2.src.rpm

Mandriva Linux 2010.1/X86_64:
f388a96a2a83aee13730d19e23b6cc1b 2010.1/x86_64/lib64tasn1_3-2.6-2.1mdv2010.2.x86_64.rpm
7f09f8240e83930c69ff4e0b5d0018ee 2010.1/x86_64/lib64tasn1-devel-2.6-2.1mdv2010.2.x86_64.rpm
03bf20288e457918f40855ee8e7a5605 2010.1/x86_64/libtasn1-tools-2.6-2.1mdv2010.2.x86_64.rpm
80d708b77aacdd9b9df4ff47005e7808 2010.1/SRPMS/libtasn1-2.6-2.1mdv2010.2.src.rpm

Mandriva Linux 2011:
3dcf447642fd754a2717641ceea8fe56 2011/i586/libtasn1_3-2.9-2.1-mdv2011.0.i586.rpm
5ea5fd4ba4a3431a517d20bd42ca2406 2011/i586/libtasn1-devel-2.9-2.1-mdv2011.0.i586.rpm
db238dcc223bc469d40748c26af0357e 2011/i586/libtasn1-tools-2.9-2.1-mdv2011.0.i586.rpm
d73a4e5fcfc4abb57dc3d309ed4d999e 2011/SRPMS/libtasn1-2.9-2.1.src.rpm

Mandriva Linux 2011/X86_64:
5822b76067fec1f477e7f9c747cd5e85 2011/x86_64/lib64tasn1_3-2.9-2.1-mdv2011.0.x86_64.rpm
64d199ac1a6252171e44ca48e4b24d40 2011/x86_64/lib64tasn1-devel-2.9-2.1-mdv2011.0.x86_64.rpm
4b1256150cedeedfcd51d3b92764ca60 2011/x86_64/libtasn1-tools-2.9-2.1-mdv2011.0.x86_64.rpm
d73a4e5fcfc4abb57dc3d309ed4d999e 2011/SRPMS/libtasn1-2.9-2.1.src.rpm

Mandriva Enterprise Server 5:
a07a6c2ed4e75e72c440c5ce64315b48 mes5/i586/libtasn1_3-1.5-2.1mdvmes5.2.i586.rpm
d6b7a20bd3c91808f02ea25740b5d904 mes5/i586/libtasn1-devel-1.5-2.1mdvmes5.2.i586.rpm
33e56c2b94ba3e3ca2736f63d7338966 mes5/i586/libtasn1-tools-1.5-2.1mdvmes5.2.i586.rpm
ee39b9f35767b2781999cbe1d32cddb4 mes5/SRPMS/libtasn1-1.5-2.1mdvmes5.2.src.rpm

Mandriva Enterprise Server 5/X86_64:
3ae9ddcc16a911f1a9a056075e34f5e2 mes5/x86_64/lib64tasn1_3-1.5-2.1mdvmes5.2.x86_64.rpm
ad2a1e9b3ed5f7a2be0e20b7565068f7 mes5/x86_64/lib64tasn1-devel-1.5-2.1mdvmes5.2.x86_64.rpm
29c794bb8047041d930d1e049b3b22d0 mes5/x86_64/libtasn1-tools-1.5-2.1mdvmes5.2.x86_64.rpm
ee39b9f35767b2781999cbe1d32cddb4 mes5/SRPMS/libtasn1-1.5-2.1mdvmes5.2.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iD8DBQFPcWttmqjQ0CJFipgRAk0KAJ9iHFpXZPn8+Y7LgMmBOv+QL7WwFACgsXvr
ey6d0f6pwR+cgJ4U/tyWTmY=
=xWwi
-----END PGP SIGNATURE-----



Relevant Pages

  • [Full-disclosure] [ MDVSA-2013:301 ] nss
    ... Business Server 1.0, Enterprise Server 5.0 ... This certificate ... Additionally the rootcerts packages has been upgraded with the latest ... Mandriva Enterprise Server 5/X86_64: ...
    (Full-Disclosure)
  • [ MDVSA-2013:301 ] nss
    ... Business Server 1.0, Enterprise Server 5.0 ... This certificate ... Additionally the rootcerts packages has been upgraded with the latest ... Mandriva Enterprise Server 5/X86_64: ...
    (Bugtraq)
  • [ MDVSA-2011:146 ] cups
    ... 2009.0, 2010.1, Enterprise Server 5.0 ... Packages for 2009.0 are provided as of the Extended Maintenance ... Mandriva Linux 2009.0/X86_64: ...
    (Bugtraq)
  • [Full-disclosure] [ MDVSA-2014:010 ] memcached
    ... Business Server 1.0, Enterprise Server 5.0 ... authentication by sending an invalid request with SASL credentials, ... Updated Packages: ... Mandriva Enterprise Server 5/X86_64: ...
    (Full-Disclosure)
  • [ MDVSA-2014:010 ] memcached
    ... Business Server 1.0, Enterprise Server 5.0 ... authentication by sending an invalid request with SASL credentials, ... Updated Packages: ... Mandriva Enterprise Server 5/X86_64: ...
    (Bugtraq)