[ MDVSA-2012:036 ] libsoup



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2012:036
http://www.mandriva.com/security/
_______________________________________________________________________

Package : libsoup
Date : March 23, 2012
Affected: 2010.1, 2011., Enterprise Server 5.0
_______________________________________________________________________

Problem Description:

A vulnerability has been found and corrected in libsoup:

Directory traversal vulnerability in soup-uri.c in SoupServer in
libsoup before 2.35.4 allows remote attackers to read arbitrary files
via a \%2e\%2e (encoded dot dot) in a URI (CVE-2011-2524).

The updated packages have been patched to correct this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-2524
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2010.1:
26726dcbd3e8e793fdf645da4185d821 2010.1/i586/libsoup-2.4_1-2.30.2-1.1mdv2010.2.i586.rpm
47b95f0b1ac8370047f58d64a4e1cc41 2010.1/i586/libsoup-2.4-devel-2.30.2-1.1mdv2010.2.i586.rpm
fbf7c3ca4f6ffbc856f2fdb935537d7f 2010.1/SRPMS/libsoup-2.30.2-1.1mdv2010.2.src.rpm

Mandriva Linux 2010.1/X86_64:
53485ec990cddcbdb3e43a5069c7f178 2010.1/x86_64/lib64soup-2.4_1-2.30.2-1.1mdv2010.2.x86_64.rpm
97398905ccc34f209196220d2d61ed20 2010.1/x86_64/lib64soup-2.4-devel-2.30.2-1.1mdv2010.2.x86_64.rpm
fbf7c3ca4f6ffbc856f2fdb935537d7f 2010.1/SRPMS/libsoup-2.30.2-1.1mdv2010.2.src.rpm

Mandriva Linux 2011:
863a97809de1062e749915712c82fa05 2011/i586/libsoup-2.4_1-2.34.2-1.1-mdv2011.0.i586.rpm
c1ef08d4a7049e2bd85c9eb9cc50ef9b 2011/i586/libsoup-2.4-devel-2.34.2-1.1-mdv2011.0.i586.rpm
0fd49f8e86882512426b5254bc7a6771 2011/SRPMS/libsoup-2.34.2-1.1.src.rpm

Mandriva Linux 2011/X86_64:
c3a45361e56d309c17fc874c7e2befe7 2011/x86_64/lib64soup-2.4_1-2.34.2-1.1-mdv2011.0.x86_64.rpm
eff744d6d1beba3b372851ce165d6d70 2011/x86_64/lib64soup-2.4-devel-2.34.2-1.1-mdv2011.0.x86_64.rpm
0fd49f8e86882512426b5254bc7a6771 2011/SRPMS/libsoup-2.34.2-1.1.src.rpm

Mandriva Enterprise Server 5:
d4e8a20b159ba5c01fc24d4552e666ac mes5/i586/libsoup-2.4_1-2.24.0.1-1.1mdvmes5.2.i586.rpm
39ef32b1d4c8dbe9a9cdb601f759a4ae mes5/i586/libsoup-2.4-devel-2.24.0.1-1.1mdvmes5.2.i586.rpm
5215645c524d5a64b7003a77e5851a39 mes5/SRPMS/libsoup-2.24.0.1-1.1mdvmes5.2.src.rpm

Mandriva Enterprise Server 5/X86_64:
dcb143bb36b1ff90efad7ade90626fae mes5/x86_64/lib64soup-2.4_1-2.24.0.1-1.1mdvmes5.2.x86_64.rpm
bc329099d3c2b37d787359794d6be289 mes5/x86_64/lib64soup-2.4-devel-2.24.0.1-1.1mdvmes5.2.x86_64.rpm
5215645c524d5a64b7003a77e5851a39 mes5/SRPMS/libsoup-2.24.0.1-1.1mdvmes5.2.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iD8DBQFPbFpwmqjQ0CJFipgRAsEUAKDVNWwbgjmYL7Qr1aYJe6rTjDpQhACdH4Cg
hvNgddFFSywWFq8X7BObZpQ=
=EQwe
-----END PGP SIGNATURE-----



Relevant Pages