[SECURITY] [DSA 2434-1] nginx security update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2434-1 security@xxxxxxxxxx
http://www.debian.org/security/ Luciano Bello
March 19, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : nginx
Vulnerability : sensitive information leak
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-1180
Debian Bug : 664137

Matthew Daley discovered a memory disclosure vulnerability in nginx. In
previous versions of this web server, an attacker can receive the content of
previously freed memory if an upstream server returned a specially crafted HTTP
response, potentially exposing sensitive information.

For the stable distribution (squeeze), this problem has been fixed in
version 0.7.67-3+squeeze2.

For the unstable distribution (sid), this problem has been fixed in
version 1.1.17-1.

We recommend that you upgrade your nginx packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@xxxxxxxxxxxxxxxx
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk9nuSsACgkQQWTRs4lLtHmBXgCfQ9bc7DxAo5RIKuPF8UgSaGxn
zXUAn3T+A7FpQ6iyr2Ebh2pIoBdPHVz2
=3d9U
-----END PGP SIGNATURE-----



Relevant Pages

  • [Full-disclosure] [SECURITY] [DSA 2434-1] nginx security update
    ... Matthew Daley discovered a memory disclosure vulnerability in nginx. ... response, potentially exposing sensitive information. ... Further information about Debian Security Advisories, ...
    (Full-Disclosure)
  • [Full-disclosure] [SECURITY] [DSA 2660-1] curl security update
    ... Vulnerability: exposure of sensitive information ... Both curl the command line tool and applications using the libcurl ... Further information about Debian Security Advisories, ...
    (Full-Disclosure)
  • [SECURITY] [DSA 2660-1] curl security update
    ... Vulnerability: exposure of sensitive information ... Both curl the command line tool and applications using the libcurl ... Further information about Debian Security Advisories, ...
    (Bugtraq)
  • [Full-disclosure] [SECURITY] [DSA 2721-1] nginx security update
    ... A buffer overflow has been identified in nginx, a small, powerful, ... The oldstable distribution, is not affected by this problem. ... We recommend that you upgrade your nginx packages. ... Further information about Debian Security Advisories, ...
    (Full-Disclosure)
  • [SECURITY] [DSA 2721-1] nginx security update
    ... A buffer overflow has been identified in nginx, a small, powerful, ... The oldstable distribution, is not affected by this problem. ... We recommend that you upgrade your nginx packages. ... Further information about Debian Security Advisories, ...
    (Bugtraq)