[ MDVSA-2012:005 ] libxml2



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2012:005
http://www.mandriva.com/security/
_______________________________________________________________________

Package : libxml2
Date : January 16, 2012
Affected: 2010.1, 2011., Enterprise Server 5.0
_______________________________________________________________________

Problem Description:

A vulnerability has been found and corrected in libxml2:

A heap-based buffer overflow in libxml2 allows remote attackers to
cause a denial of service or possibly have unspecified other impact
via unknown vectors (CVE-2011-3919).

The updated packages have been patched to correct this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3919
http://googlechromereleases.blogspot.com/2012/01/stable-channel-update.html
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2010.1:
a0bbc482eaa1931424d48678cb87a3e9 2010.1/i586/libxml2_2-2.7.7-1.6mdv2010.2.i586.rpm
ee0cd09602637cbe33cabef7ef4e1da8 2010.1/i586/libxml2-devel-2.7.7-1.6mdv2010.2.i586.rpm
9dcc2f9c640eb2735e19b4f83b4f5669 2010.1/i586/libxml2-python-2.7.7-1.6mdv2010.2.i586.rpm
a96d2c2a01ae190e53c96a4b44aba209 2010.1/i586/libxml2-utils-2.7.7-1.6mdv2010.2.i586.rpm
ff4a02aade89dae40a9a5609221ec839 2010.1/SRPMS/libxml2-2.7.7-1.6mdv2010.2.src.rpm

Mandriva Linux 2010.1/X86_64:
a49f74035c061d09f6bad4cbefdc45db 2010.1/x86_64/lib64xml2_2-2.7.7-1.6mdv2010.2.x86_64.rpm
1ce649c61221c5f9c9e31cf0a94936aa 2010.1/x86_64/lib64xml2-devel-2.7.7-1.6mdv2010.2.x86_64.rpm
7e67eb475cc41e4e977b01f817acd49a 2010.1/x86_64/libxml2-python-2.7.7-1.6mdv2010.2.x86_64.rpm
29f376494f5f53dbb3e99da560afd0a6 2010.1/x86_64/libxml2-utils-2.7.7-1.6mdv2010.2.x86_64.rpm
ff4a02aade89dae40a9a5609221ec839 2010.1/SRPMS/libxml2-2.7.7-1.6mdv2010.2.src.rpm

Mandriva Linux 2011:
70e4d0c03221ef3b6cc69f338b54657e 2011/i586/libxml2_2-2.7.8-6.4-mdv2011.0.i586.rpm
1997ac61c6937f6640305b6e88733180 2011/i586/libxml2-devel-2.7.8-6.4-mdv2011.0.i586.rpm
e05e326d877954adca343564b3b1fe77 2011/i586/libxml2-python-2.7.8-6.4-mdv2011.0.i586.rpm
937859f1d5d7d1ae3ddb543ced2907ed 2011/i586/libxml2-utils-2.7.8-6.4-mdv2011.0.i586.rpm
dfc48e36cba257adaa0a7d1f57452744 2011/SRPMS/libxml2-2.7.8-6.4.src.rpm

Mandriva Linux 2011/X86_64:
55a7a6f456b260edd6cd21f852e9653f 2011/x86_64/lib64xml2_2-2.7.8-6.4-mdv2011.0.x86_64.rpm
d0bf38766f527548bdeaf19cb0491a73 2011/x86_64/lib64xml2-devel-2.7.8-6.4-mdv2011.0.x86_64.rpm
a64043b51b9aa510f8c681d199d5da80 2011/x86_64/libxml2-python-2.7.8-6.4-mdv2011.0.x86_64.rpm
1d86455c580c5dcd7d89642119cb6c8f 2011/x86_64/libxml2-utils-2.7.8-6.4-mdv2011.0.x86_64.rpm
dfc48e36cba257adaa0a7d1f57452744 2011/SRPMS/libxml2-2.7.8-6.4.src.rpm

Mandriva Enterprise Server 5:
bf4eeba3bca82dd36e7f88d15bc3f623 mes5/i586/libxml2_2-2.7.1-1.10mdvmes5.2.i586.rpm
7ebf1be5bf0deb81bdf7e4700ef7ec81 mes5/i586/libxml2-devel-2.7.1-1.10mdvmes5.2.i586.rpm
8b4e729c579eafdd98df18793068a56e mes5/i586/libxml2-python-2.7.1-1.10mdvmes5.2.i586.rpm
08b93d92bb0467cc1db9aa247ec9d96f mes5/i586/libxml2-utils-2.7.1-1.10mdvmes5.2.i586.rpm
55cbcf397b1faf40b2917c4df8cdf83c mes5/SRPMS/libxml2-2.7.1-1.10mdvmes5.2.src.rpm

Mandriva Enterprise Server 5/X86_64:
734e12b30ef26a06e6d93473987bde4a mes5/x86_64/lib64xml2_2-2.7.1-1.10mdvmes5.2.x86_64.rpm
f9e8909c3130bcc8aaecd88ac0ffab3c mes5/x86_64/lib64xml2-devel-2.7.1-1.10mdvmes5.2.x86_64.rpm
95db6901f60f87abb48dd2f36b2df0d9 mes5/x86_64/libxml2-python-2.7.1-1.10mdvmes5.2.x86_64.rpm
5abdc9be62db152aa664a27409e80e48 mes5/x86_64/libxml2-utils-2.7.1-1.10mdvmes5.2.x86_64.rpm
55cbcf397b1faf40b2917c4df8cdf83c mes5/SRPMS/libxml2-2.7.1-1.10mdvmes5.2.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iD8DBQFPFDdAmqjQ0CJFipgRAvaFAKDbqaZpFDpJfd+u5rffy8dVc4q/mgCgzT78
XTYLcE4y6Ik2JLO5kKH5jZ0=
=/sL7
-----END PGP SIGNATURE-----



Relevant Pages

  • [Full-disclosure] [ MDVSA-2013:301 ] nss
    ... Business Server 1.0, Enterprise Server 5.0 ... This certificate ... Additionally the rootcerts packages has been upgraded with the latest ... Mandriva Enterprise Server 5/X86_64: ...
    (Full-Disclosure)
  • [ MDVSA-2013:301 ] nss
    ... Business Server 1.0, Enterprise Server 5.0 ... This certificate ... Additionally the rootcerts packages has been upgraded with the latest ... Mandriva Enterprise Server 5/X86_64: ...
    (Bugtraq)
  • [ MDVSA-2011:146 ] cups
    ... 2009.0, 2010.1, Enterprise Server 5.0 ... Packages for 2009.0 are provided as of the Extended Maintenance ... Mandriva Linux 2009.0/X86_64: ...
    (Bugtraq)
  • [Full-disclosure] [ MDVSA-2014:010 ] memcached
    ... Business Server 1.0, Enterprise Server 5.0 ... authentication by sending an invalid request with SASL credentials, ... Updated Packages: ... Mandriva Enterprise Server 5/X86_64: ...
    (Full-Disclosure)
  • [ MDVSA-2014:010 ] memcached
    ... Business Server 1.0, Enterprise Server 5.0 ... authentication by sending an invalid request with SASL credentials, ... Updated Packages: ... Mandriva Enterprise Server 5/X86_64: ...
    (Bugtraq)