HTB22822: XSS vulnerability in RunCMS

Vulnerability ID: HTB22822
Product: RunCMS
Vendor: ( )
Vulnerable Version: 2.2.2
Vendor Notification: 27 January 2011
Vulnerability Type: XSS (Cross Site Scripting)
Risk level: Medium
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.
The vulnerability exists due to failure in the "/user.php" script to properly sanitize user-supplied input in "rc2_user" variable from cookies.
Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data.

The following PoC is available:

GET /user.php HTTP/1.1
Cookie: rc2_user='><script>alert("XSS")%3b</script>

Relevant Pages