SQL injection in eoCMS



Vulnerability ID: HTB22675
Reference: http://www.htbridge.ch/advisory/sql_injection_in_eocms.html
Product: eoCMS
Vendor: eocms.com ( http://eocms.com )
Vulnerable Version: 0.9.04
Vendor Notification: 21 October 2010
Vulnerability Type: SQL Injection
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response
Risk level: High
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details:
The vulnerability exists due to failure in the "index.php" script to properly sanitize user-supplied input in eocms value from cookies.
Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.

The following PoC is available:


GET /index.php HTTP/1.0
Cookie: eocms='SQL_CODE_HERE



Relevant Pages