[ MDVSA-2009:332 ] gimp




-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2009:332
http://www.mandriva.com/security/
_______________________________________________________________________

Package : gimp
Date : December 11, 2009
Affected: 2009.1, 2010.0
_______________________________________________________________________

Problem Description:

A vulnerability was discovered and corrected in gimp:

Integer overflow in the read_channel_data function in
plug-ins/file-psd/psd-load.c in GIMP 2.6.7 might allow remote attackers
to execute arbitrary code via a crafted PSD file that triggers a
heap-based buffer overflow (CVE-2009-3909).

Additionally the patch for CVE-2009-1570 in MDVSA-2009:296 was
incomplete, this update corrects this as well.

This update provides a solution to this vulnerability.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3909
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2009.1:
fa558f5ff6967b9b2e1339be5edb4dae 2009.1/i586/gimp-2.6.6-3.2mdv2009.1.i586.rpm
1810d6d75ccaa4be789331652e2e646b 2009.1/i586/gimp-python-2.6.6-3.2mdv2009.1.i586.rpm
5f3aa201fd430a9d2292c60106a7cd4f 2009.1/i586/libgimp2.0_0-2.6.6-3.2mdv2009.1.i586.rpm
f7fbcaf7ec8c86f2ca2a385d29e0f832 2009.1/i586/libgimp2.0-devel-2.6.6-3.2mdv2009.1.i586.rpm
5a4bb71d1ea5aa452225c2e9f1e37346 2009.1/SRPMS/gimp-2.6.6-3.2mdv2009.1.src.rpm

Mandriva Linux 2009.1/X86_64:
e6d85646179c119353ce6b84e37f5906 2009.1/x86_64/gimp-2.6.6-3.2mdv2009.1.x86_64.rpm
2dea8cbca0edd767c7e28ed5b8f4821f 2009.1/x86_64/gimp-python-2.6.6-3.2mdv2009.1.x86_64.rpm
b92fe0290e5e9d23f7fe55e821d56dd4 2009.1/x86_64/lib64gimp2.0_0-2.6.6-3.2mdv2009.1.x86_64.rpm
85c9c31b5f8ef1b9462c7e7ad7ab89d0 2009.1/x86_64/lib64gimp2.0-devel-2.6.6-3.2mdv2009.1.x86_64.rpm
5a4bb71d1ea5aa452225c2e9f1e37346 2009.1/SRPMS/gimp-2.6.6-3.2mdv2009.1.src.rpm

Mandriva Linux 2010.0:
0937992f9dac9759e581a8fe3da308f9 2010.0/i586/gimp-2.6.7-4.2mdv2010.0.i586.rpm
e00452005dd8c438416a4cb4dfdf4237 2010.0/i586/gimp-python-2.6.7-4.2mdv2010.0.i586.rpm
e88978c421174f022081683e22fd8c22 2010.0/i586/libgimp2.0_0-2.6.7-4.2mdv2010.0.i586.rpm
ca93895eda99b5285e570a82b8044c4e 2010.0/i586/libgimp2.0-devel-2.6.7-4.2mdv2010.0.i586.rpm
9f70e273efe492b8261d369f6812dccd 2010.0/SRPMS/gimp-2.6.7-4.2mdv2010.0.src.rpm

Mandriva Linux 2010.0/X86_64:
847d2a698c76b51de51d58c0e81bb738 2010.0/x86_64/gimp-2.6.7-4.2mdv2010.0.x86_64.rpm
762c98f5123f022a2def25e04500eed9 2010.0/x86_64/gimp-python-2.6.7-4.2mdv2010.0.x86_64.rpm
4624eddf6ceefcc86cffc9dc1e0284b6 2010.0/x86_64/lib64gimp2.0_0-2.6.7-4.2mdv2010.0.x86_64.rpm
a958ee9fe15c253c12f6f875ef23363c 2010.0/x86_64/lib64gimp2.0-devel-2.6.7-4.2mdv2010.0.x86_64.rpm
9f70e273efe492b8261d369f6812dccd 2010.0/SRPMS/gimp-2.6.7-4.2mdv2010.0.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFLIiMsmqjQ0CJFipgRAjVfAJ0ehyIM/R8/XIKoMJ5/XzVz8yGLRACg8xM2
rDgiQLLbIbRWFDL8qNC9X6s=
=DHsP
-----END PGP SIGNATURE-----



Relevant Pages

  • [Full-disclosure] [ MDVSA-2010:073-1 ] cups
    ... Use-after-free vulnerability in the abstract file-descriptor handling ... scheduler in cupsd in CUPS 1.3.7 and 1.3.10 allows remote attackers ... The updated packages have been patched to correct these issues. ... Packages for Mandriva Linux 2010.0 was missing with ...
    (Full-Disclosure)
  • [ MDVSA-2010:073-1 ] cups
    ... Use-after-free vulnerability in the abstract file-descriptor handling ... scheduler in cupsd in CUPS 1.3.7 and 1.3.10 allows remote attackers ... The updated packages have been patched to correct these issues. ... Packages for Mandriva Linux 2010.0 was missing with ...
    (Bugtraq)
  • [Full-disclosure] [ MDVSA-2010:084 ] java-1.6.0-openjdk
    ... Multiple Java OpenJDK security vulnerabilities has been identified ... CMM readMabCurveData Buffer Overflow Vulnerability. ... Packages for 2009.0 are provided due to the Extended Maintenance ... Mandriva Linux 2009.0/X86_64: ...
    (Full-Disclosure)
  • [ MDVSA-2010:084 ] java-1.6.0-openjdk
    ... Multiple Java OpenJDK security vulnerabilities has been identified ... CMM readMabCurveData Buffer Overflow Vulnerability. ... Packages for 2009.0 are provided due to the Extended Maintenance ... Mandriva Linux 2009.0/X86_64: ...
    (Bugtraq)
  • [Full-disclosure] [ MDKSA-2007:079-1 ] - Updated xorg-x11/XFree86 packages fix i
    ... Local exploitation of a memory corruption vulnerability in the X.Org ... Updated packages are patched to address these issues. ... Packages for Mandriva Linux 2007.1 are now available. ...
    (Full-Disclosure)