rPSA-2006-0187-1 idle python



rPath Security Advisory: 2006-0187-1
Published: 2006-10-10
Products: rPath Linux 1
Rating: Major
Exposure Level Classification:
Indirect Deterministic Weakness
Updated Versions:
idle=/conary.rpath.com@rpl:devel//1/2.4.1-20.7-1
python=/conary.rpath.com@rpl:devel//1/2.4.1-20.7-1

References:
http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4980
https://issues.rpath.com/browse/RPL-625
https://issues.rpath.com/browse/RPL-702

Description:
Previous versions of the python package have two weaknesses that
may trigger vulnerabilities in programs that use python. Any
program that uses repr() on arbitrary unchecked user-supplied
unicode strings was vulnerable to a Denial of Service attack and
may be vulnerable to a privilege escalation or unauthorized
access attack, depending on the context in which it is used.
Additionally, some programs that use email.Utils may have
vulnerabilities which could have been exposed by a weakness
in parsing RFC 2231 headers in those previous versions.



Relevant Pages

  • [Full-disclosure] rPSA-2006-0187-1 idle python
    ... rPath Security Advisory: 2006-0187-1 ... Indirect Deterministic Weakness ... Previous versions of the python package have two weaknesses that ... may trigger vulnerabilities in programs that use python. ...
    (Full-Disclosure)
  • [Full-disclosure] rPSA-2006-0207-1 openssh openssh-client openssh-server
    ... rPath Security Advisory: 2006-0207-1 ... Previous versions of the openssh package contain a weakness in the ... vulnerabilities are currently known to be enabled by this weakness. ...
    (Full-Disclosure)
  • rPSA-2006-0207-1 openssh openssh-client openssh-server
    ... rPath Security Advisory: 2006-0207-1 ... Previous versions of the openssh package contain a weakness in the ... vulnerabilities are currently known to be enabled by this weakness. ...
    (Bugtraq)
  • [Full-disclosure] rPSA-2006-0133-1 libpng
    ... rPath Security Advisory: 2006-0133-1 ... User Non-deterministic Unauthorized Access ... This weakness is triggered by malformed png images that may be ...
    (Full-Disclosure)
  • rPSA-2006-0133-1 libpng
    ... rPath Security Advisory: 2006-0133-1 ... User Non-deterministic Unauthorized Access ... This weakness is triggered by malformed png images that may be ...
    (Bugtraq)