[SECURITY] [DSA 1075-1] New awstats packages fix arbitrary command execution



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1075-1 security@xxxxxxxxxx
http://www.debian.org/security/ Martin Schulze
May 26th, 2006 http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package : awstats
Vulnerability : programming error
Problem type : remote
Debian-specific: no
Debian Bug : 365910

Hendrik Weimer discovered that awstats can execute arbitrary commands
under the user id the web-server runs when users are allowed to supply
arbitrary configuration files. Even though, this bug was referenced
in DSA 1058 accidently, it was not fixed yet.

The new default behaviour is not ao accept arbitrary configuration
directories from the user. This can be overwritten by the
AWSTATS_ENABLE_CONFIG_DIR environment variable when users are to be
trusted.

The old stable distribution (woody) does not seem to be affected by
this problem.

For the stable distribution (sarge) this problem has been fixed in
version 6.4-1sarge3.

For the unstable distribution (sid) this problem has been fixed in
version 6.5-2.

We recommend that you upgrade your awstats package.


Upgrade Instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given at the end of this advisory:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

Source archives:

http://security.debian.org/pool/updates/main/a/awstats/awstats_6.4-1sarge3.dsc
Size/MD5 checksum: 589 c89ec8be4c06c290950e1da615b4e215
http://security.debian.org/pool/updates/main/a/awstats/awstats_6.4-1sarge3.diff.gz
Size/MD5 checksum: 19145 fb59598c0a1ddd970c48bed857c0b364
http://security.debian.org/pool/updates/main/a/awstats/awstats_6.4.orig.tar.gz
Size/MD5 checksum: 918435 056e6fb0c7351b17fe5bbbe0aa1297b1

Architecture independent components:

http://security.debian.org/pool/updates/main/a/awstats/awstats_6.4-1sarge3_all.deb
Size/MD5 checksum: 728706 395a9e5acb69dcc50da9cf88ed9a89da


These files will probably be moved into the stable distribution on
its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@xxxxxxxxxxxxxxxx
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFEdr68W5ql+IAeqTIRAsirAKC8AhDQD/wLtBFt8crQ9gKryFmAlgCgmL37
BNdO6srzkyTcLgvNPoreoig=
=Hbqh
-----END PGP SIGNATURE-----



Relevant Pages