[eVuln] geoBlog SQL Injection Vulnerability

New eVuln Advisory:
geoBlog SQL Injection Vulnerability


Software: geoBlog
Sowtware's Web Site: http://sourceforge.net/projects/bitdamaged/
Versions: MOD_1.0
Critical Level: Dangerous
Type: SQL Injection
Class: Remote
Status: Unpatched
Exploit: Available
Solution: Not Available
Discovered by: Aliaksandr Hartsuyeu (eVuln.com)
eVuln ID: EV0033

Vulnerable script:

Variable $tmpCategory isn't properly sanitized before being used in a SQL query. This can be used to make any SQL query by injecting arbitrary SQL code.

Condition: gpc_magic_quotes - off

Administrator's login name and password's hash storing in database.
Administrator has an ability to upload arbitrary files which will be stored in /files directory.

System access is possible.

Available at: http://evuln.com/vulns/33/exploit/bt/

No Patch available.

Discovered by: Aliaksandr Hartsuyeu (eVuln.com)

Relevant Pages