[ GLSA 200501-45 ] Gallery: Cross-site scripting vulnerability

From: Luke Macken (lewk_at_gentoo.org)
Date: 01/30/05

  • Next message: Black Dot: "Re: Winamp Exploit (POC) 5.08 Stack Overflow"
    Date: Sun, 30 Jan 2005 15:53:33 -0500
    To: gentoo-announce@gentoo.org
    
    
    

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory GLSA 200501-45
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

      Severity: Low
         Title: Gallery: Cross-site scripting vulnerability
          Date: January 30, 2005
          Bugs: #78522
            ID: 200501-45

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Synopsis
    ========

    Gallery is vulnerable to cross-site scripting attacks.

    Background
    ==========

    Gallery is a web application written in PHP which is used to organize
    and publish photo albums. It allows multiple users to build and
    maintain their own albums. It also supports the mirroring of images on
    other servers.

    Affected packages
    =================

        -------------------------------------------------------------------
         Package / Vulnerable / Unaffected
        -------------------------------------------------------------------
      1 www-apps/gallery <= 1.4.4_p4 >= 1.4.4_p5

    Description
    ===========

    Rafel Ivgi has discovered a cross-site scripting vulnerability where
    the 'username' parameter is not properly sanitized in 'login.php'.

    Impact
    ======

    By sending a carefully crafted URL, an attacker can inject and execute
    script code in the victim's browser window, and potentially compromise
    the user's gallery.

    Workaround
    ==========

    There is no known workaround at this time.

    Resolution
    ==========

    All Gallery users should upgrade to the latest version:

        # emerge --sync
        # emerge --ask --oneshot --verbose ">=www-apps/gallery-1.4.4_p5"

    References
    ==========

      [ 1 ] Gallery Announcement
            http://gallery.menalto.com/modules.php?op=modload&name=News&file=article&sid=147
      [ 2 ] Secunia Advisory SA13887
            http://secunia.com/advisories/13887/

    Availability
    ============

    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200501-45.xml

    Concerns?
    =========

    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    security@gentoo.org or alternatively, you may file a bug at
    http://bugs.gentoo.org.

    License
    =======

    Copyright 2005 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).

    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.

    http://creativecommons.org/licenses/by-sa/2.0

    
    



  • Next message: Black Dot: "Re: Winamp Exploit (POC) 5.08 Stack Overflow"

    Relevant Pages