[CLA-2005:917] Conectiva Security Announcement - krb5

From: Conectiva Updates (secure_at_conectiva.com.br)
Date: 01/13/05

  • Next message: Hyperdose Security: "Cross Site Scripting holes found in Horde 3.0"
    Date: Thu, 13 Jan 2005 11:56:32 -0200
    To: conectiva-updates@papaleguas.conectiva.com.br, lwn@lwn.net, bugtraq@securityfocus.com, security-alerts@linuxsecurity.com, linsec@lists.seifried.org
    
    

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    - --------------------------------------------------------------------------
    CONECTIVA LINUX SECURITY ANNOUNCEMENT
    - --------------------------------------------------------------------------

    PACKAGE : krb5
    SUMMARY : Fix for buffer overflow in libkadm5srv
    DATE : 2005-01-13 11:56:00
    ID : CLA-2005:917
    RELEVANT
    RELEASES : 9, 10

    - -------------------------------------------------------------------------

    DESCRIPTION
     The "krb5" packages are MIT's[1] implementation of the Kerberos 5
     authentication protocol.
     
     Michael Tautschnig noticed that the MIT Kerberos 5 administration
     library (libkadm5srv) contains a heap buffer overflow[2] in password
     history handling code which could be exploited by an authenticated
     user to execute arbitrary code on a Key Distribution Center (KDC)
     host.
     
     For further information about this vulnerability, please refer to MIT
     krb5 Security Advisory 2004-004[3].

    SOLUTION
     It is recommended that all Kerberos users in Conectiva Linux upgrade
     their packages. Please note that the service will be automatically
     restarted after the upgrade if it was already running.
     
     Several applications can make use of the Kerberos libraries. Those
     applications have to be restarted as well.
     
     
     REFERENCES
     1.http://web.mit.edu/Kerberos/www/index.html
     2.http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1189
     3.http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2004-004-pwhist.txt

    UPDATED PACKAGES
    ftp://atualizacoes.conectiva.com.br/10/SRPMS/krb5-1.3.3-62470U10_3cl.src.rpm
    ftp://atualizacoes.conectiva.com.br/10/RPMS/krb5-1.3.3-62470U10_3cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/10/RPMS/krb5-apps-clients-1.3.3-62470U10_3cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/10/RPMS/krb5-apps-servers-1.3.3-62470U10_3cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/10/RPMS/krb5-client-1.3.3-62470U10_3cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/10/RPMS/krb5-devel-1.3.3-62470U10_3cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/10/RPMS/krb5-devel-static-1.3.3-62470U10_3cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/10/RPMS/krb5-doc-1.3.3-62470U10_3cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/10/RPMS/krb5-server-1.3.3-62470U10_3cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/9/SRPMS/krb5-1.2.7-28721U90_4cl.src.rpm
    ftp://atualizacoes.conectiva.com.br/9/RPMS/krb5-1.2.7-28721U90_4cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/9/RPMS/krb5-apps-clients-1.2.7-28721U90_4cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/9/RPMS/krb5-apps-servers-1.2.7-28721U90_4cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/9/RPMS/krb5-client-1.2.7-28721U90_4cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/9/RPMS/krb5-devel-1.2.7-28721U90_4cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/9/RPMS/krb5-devel-static-1.2.7-28721U90_4cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/9/RPMS/krb5-doc-1.2.7-28721U90_4cl.i386.rpm
    ftp://atualizacoes.conectiva.com.br/9/RPMS/krb5-server-1.2.7-28721U90_4cl.i386.rpm

    ADDITIONAL INSTRUCTIONS
     The apt tool can be used to perform RPM packages upgrades:

     - run: apt-get update
     - after that, execute: apt-get upgrade

     Detailed instructions regarding the use of apt and upgrade examples
     can be found at http://distro.conectiva.com.br/atualizacoes/#apt?idioma=en

    - -------------------------------------------------------------------------
    All packages are signed with Conectiva's GPG key. The key and instructions
    on how to import it can be found at
    http://distro.conectiva.com.br/seguranca/chave/?idioma=en
    Instructions on how to check the signatures of the RPM packages can be
    found at http://distro.conectiva.com.br/seguranca/politica/?idioma=en

    - -------------------------------------------------------------------------
    All our advisories and generic update instructions can be viewed at
    http://distro.conectiva.com.br/atualizacoes/?idioma=en

    - -------------------------------------------------------------------------
    Copyright (c) 2004 Conectiva Inc.
    http://www.conectiva.com

    - -------------------------------------------------------------------------
    subscribe: conectiva-updates-subscribe@papaleguas.conectiva.com.br
    unsubscribe: conectiva-updates-unsubscribe@papaleguas.conectiva.com.br
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.0.6 (GNU/Linux)
    Comment: For info see http://www.gnupg.org

    iD8DBQFB5n4P42jd0JmAcZARAufhAJ9Qk3MYg3B2WqDBhqQW5jWijjEe8wCfegBK
    BEDm+Xa9SFzQfs/ebpI4pvI=
    =DQRK
    -----END PGP SIGNATURE-----


  • Next message: Hyperdose Security: "Cross Site Scripting holes found in Horde 3.0"

    Relevant Pages