[ GLSA 200411-23 ] Ruby: Denial of Service issue

From: Thierry Carrez (koon_at_gentoo.org)
Date: 11/16/04

  • Next message: Martin Schulze: "[SECURITY] [DSA 594-1] New Apache packages fix arbitrary code execution"
    Date: Tue, 16 Nov 2004 10:56:16 +0100
    To: gentoo-announce@gentoo.org
    
    
    

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory GLSA 200411-23
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

      Severity: Normal
         Title: Ruby: Denial of Service issue
          Date: November 16, 2004
          Bugs: #69985
            ID: 200411-23

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Synopsis
    ========

    The CGI module in Ruby can be sent into an infinite loop, resulting in
    a Denial of Service condition.

    Background
    ==========

    Ruby is an interpreted scripting language for quick and easy
    object-oriented programming. Ruby's CGI module can be used to build web
    applications.

    Affected packages
    =================

        -------------------------------------------------------------------
         Package / Vulnerable / Unaffected
        -------------------------------------------------------------------
      1 dev-lang/ruby < 1.8.2_pre3 *>= 1.6.8-r12
    >= 1.8.2_pre3

    Description
    ===========

    Ruby's developers found and fixed an issue in the CGI module that can
    be triggered remotely and cause an infinite loop.

    Impact
    ======

    A remote attacker could trigger the vulnerability through an exposed
    Ruby web application and cause the server to use unnecessary CPU
    resources, potentially resulting in a Denial of Service.

    Workaround
    ==========

    There is no known workaround at this time.

    Resolution
    ==========

    All Ruby 1.6.x users should upgrade to the latest version:

        # emerge --sync
        # emerge --ask --oneshot --verbose ">=dev-lang/ruby-1.6.8-r12"

    All Ruby 1.8.x users should upgrade to the latest version:

        # emerge --sync
        # emerge --ask --oneshot --verbose ">=dev-lang/ruby-1.8.2_pre3"

    References
    ==========

      [ 1 ] CAN-2004-0983
            http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0983

    Availability
    ============

    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200411-23.xml

    Concerns?
    =========

    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    security@gentoo.org or alternatively, you may file a bug at
    http://bugs.gentoo.org.

    License
    =======

    Copyright 2004 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).

    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.

    http://creativecommons.org/licenses/by-sa/2.0

    
    



  • Next message: Martin Schulze: "[SECURITY] [DSA 594-1] New Apache packages fix arbitrary code execution"

    Relevant Pages