[ GLSA 200410-05 ] Cyrus-SASL: Buffer overflow and SASL_PATH vulnerabilities

From: Kurt Lieber (klieber_at_gentoo.org)
Date: 10/07/04

  • Next message: Luigi Auriemma: "Server crash in Flash Messaging 5.2.0g"
    Date: Thu, 7 Oct 2004 14:03:50 +0000
    To: gentoo-announce@lists.gentoo.org
    
    
    

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory GLSA 200410-05
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

      Severity: High
         Title: Cyrus-SASL: Buffer overflow and SASL_PATH vulnerabilities
          Date: October 07, 2004
          Bugs: #56016
            ID: 200410-05

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Synopsis
    ========

    Cyrus-SASL contains two vulnerabilities that might allow an attacker to
    completely compromise the vulnerable system.

    Background
    ==========

    Cyrus-SASL is an implementation of the Simple Authentication and
    Security Layer.

    Affected packages
    =================

        -------------------------------------------------------------------
         Package / Vulnerable / Unaffected
        -------------------------------------------------------------------
      1 dev-libs/cyrus-sasl <= 2.1.18-r1 >= 2.1.18-r2

    Description
    ===========

    Cyrus-SASL contains a remote buffer overflow in the digestmda5.c file.
    Additionally, under certain conditions it is possible for a local user
    to exploit a vulnerability in the way the SASL_PATH environment
    variable is honored (CAN-2004-0884).

    Impact
    ======

    An attacker might be able to execute arbitrary code with the Effective
    ID of the application calling the Cyrus-SASL libraries.

    Workaround
    ==========

    There is no known workaround at this time.

    Resolution
    ==========

    All Cyrus-SASL users should upgrade to the latest stable version:

        # emerge sync

        # emerge -pv ">=dev-libs/cyrus-sasl-2.1.18-r2"
        # emerge ">=dev-libs/cyrus-sasl-2.1.18-r2"

    References
    ==========

      [ 1 ] CAN-2004-0884
            http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0884

    Availability
    ============

    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200410-05.xml

    Concerns?
    =========

    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    security@gentoo.org or alternatively, you may file a bug at
    http://bugs.gentoo.org.

    License
    =======

    Copyright 2004 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).

    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.

    http://creativecommons.org/licenses/by-sa/1.0

    
    



  • Next message: Luigi Auriemma: "Server crash in Flash Messaging 5.2.0g"

    Relevant Pages