Solution for bugtraq id 10570 (Epic Games Unreal Engine Memory Corruption Vulnerability)

From: Gerco Dries (gerco_at_gdries.com)
Date: 06/23/04

  • Next message: snsadv: "[SNS Advisory No.76] Printing from Internet Explorer Lets Users to Cause DoS"
    To: <bugtraq@securityfocus.com>, <bugs@securitytracker.com>, <news@securiteam.com>, <full-disclosure@lists.netsys.com>
    Date: Wed, 23 Jun 2004 20:09:25 +0200
    
    

    Hi everyone,

    I have created a simple UnrealScript patch for this vulnerability in Unreal
    Tournament v436 and v451(b). As far as I know it does not negatively affect
    the functioning of the "\secure\" query or anything else, but it has not
    been extensively tested.

    You can download the patch at http://www.gdries.com/IpServer.u .

    I will attempt to create a UT2003 version of the patch as well if Epic/Atari
    doesn't provide one in a few days.

    Regards,
    Gerco Dries.


  • Next message: snsadv: "[SNS Advisory No.76] Printing from Internet Explorer Lets Users to Cause DoS"