TSLSA-2004-0010 - libxml2

From: Trustix Security Advisor (tsl_at_trustix.org)
Date: 03/06/04

  • Next message: kang: "Safari javascript array overflow"
    Date: Sat, 6 Mar 2004 14:52:26 +0100
    To: bugtraq@securityfocus.com
    
    

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    - --------------------------------------------------------------------------
    Trustix Secure Linux Security Advisory #2004-0010

    Package name: libxml2
    Summary: buffer overrun in nanohttp
    Date: 2004-03-05
    Affected versions: Trustix 2.0

    - --------------------------------------------------------------------------
    Package description:
      This library allows to manipulate XML files. It includes support
      to read, modify and write XML and HTML files.

    Problem description:
      URLs longer than 4096 bytes would cause an overflow while using nanohttp
      in libxml2.

    Action:
      We recommend that all systems with this package installed be upgraded.
      Please note that if you do not need the functionality provided by this
      package, you may want to remove it from your system.

    Location:
      All Trustix updates are available from
      <URI:http://http.trustix.org/pub/trustix/updates/>
      <URI:ftp://ftp.trustix.org/pub/trustix/updates/>

    About Trustix Secure Linux:
      Trustix Secure Linux is a small Linux distribution for servers. With focus
      on security and stability, the system is painlessly kept safe and up to
      date from day one using swup, the automated software updater.

    Automatic updates:
      Users of the SWUP tool can enjoy having updates automatically
      installed using 'swup --upgrade'.

    Public testing:
      Most updates for Trustix are made available for public testing some time
      before release.
      If you want to contribute by testing the various packages in the
      testing tree, please feel free to share your findings on the
      tsl-discuss mailinglist.
      The testing tree is located at
      <URI:http://tsldev.trustix.org/cloud/>

      You may also use swup for public testing of updates:
      
      site {
          class = 0
          location = "http://tsldev.trustix.org/cloud/rdfs/latest.rdf"
          regexp = ".*"
      }
      

    Questions?
      Check out our mailing lists:
      <URI:http://www.trustix.org/support/>

    Verification:
      This advisory along with all Trustix packages are signed with the
      TSL sign key.
      This key is available from:
      <URI:http://www.trustix.org/TSL-SIGN-KEY>

      The advisory itself is available from the errata pages at
      <URI:http://www.trustix.org/errata/trustix-2.0/>
      or directly at
      <URI:http://www.trustix.org/errata/misc/2004/TSL-2004-0010-libxml2.asc.txt>

    MD5sums of the packages:
    - --------------------------------------------------------------------------
    13066c223f0c3148eb69cfd399ea3f14 2.0/rpms/libxml2-2.5.10-1tr.i586.rpm
    b0a80332a30d823552dc99a13ffbf689 2.0/rpms/libxml2-devel-2.5.10-1tr.i586.rpm
    f58ec53e75a663aee96b7e472d01874f 2.0/rpms/libxml2-python-2.5.10-1tr.i586.rpm
    2a048d808097e162648d7f31f6c0ada5 2.0/srpms/libxml2-2.5.10-1tr.src.rpm
    - --------------------------------------------------------------------------

    Trustix Security Team

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.2 (GNU/Linux)

    iD8DBQFASK8Ei8CEzsK9IksRAlmZAKC6aFKwT15n2LKkY7H1JGSFRWD8ywCdHGGE
    GJx7SovoxEdiZWCV6Jy1bKc=
    =fzDy
    -----END PGP SIGNATURE-----


  • Next message: kang: "Safari javascript array overflow"

    Relevant Pages

    • TSLSA-2004-0040 - libpng
      ... Package name: libpng ... Affected versions: Trustix Secure Linux 2.0 ... This update fixed the following security vulnerabilities: ... All Trustix Secure Linux updates are available from ...
      (Bugtraq)
    • TSLSA-2004-0055 - multi
      ... Package name: libxml2, postgresql ... Affected versions: Trustix Secure Linux 2.0 ... 1)There is a buffer overflow when parsing a URL with ftp information ... All Trustix Secure Linux updates are available from ...
      (Bugtraq)
    • TSLSA-2004-0033 - squid
      ... Affected versions: Trustix Secure Linux 2.0 ... Package description: ... Squid is a high-performance proxy caching server for Web clients, ... All Trustix Secure Linux updates are available from ...
      (Bugtraq)
    • TSLSA-2004-0009 - nfs-utils
      ... Package name: nfs-utils ... All Trustix updates are available from ... About Trustix Secure Linux: ... Most updates for Trustix are made available for public testing some time ...
      (Bugtraq)
    • TSL-2004-0036 - kerberos
      ... Package name: kerberos5 ... Affected versions: Trustix Secure Linux 2.1 ... Kerberos is a network authentication protocol. ... All Trustix Secure Linux updates are available from ...
      (Bugtraq)