RE: ssh hangs after SSH2_MSG_SERVICE_ACCEPT



Is this only occurring during debug sessions?

-T

-----Original Message-----
From: listbounce@xxxxxxxxxxxxxxxxx [mailto:listbounce@xxxxxxxxxxxxxxxxx] On Behalf Of Kosala Atapattu
Sent: Saturday, July 24, 2010 11:57 PM
To: secureshell@xxxxxxxxxxxxxxxxx
Subject: ssh hangs after SSH2_MSG_SERVICE_ACCEPT

Hi All,

My servers suddenly started giving problem across all the machines.
When I try to connect, the ssh debug output stops near the
SSH2_MSG_SERVICE_ACCEPT and then continues after a minute or so.

root@s2spr1[/home/root] #ssh -v t1was1_nim
OpenSSH_5.2p1, OpenSSL 0.9.8k 25 Mar 2009
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Failed dlopen: /usr/krb5/lib/libkrb5.a(libkrb5.a.so):
0509-022 Cannot load module /usr/krb5/lib/libkrb5.a(libkrb5.a.so).
0509-026 System error: A file or directory in the path name
does not exist.

debug1: Error loading Kerberos, disabling Kerberos auth.
debug1: Connecting to t1was1_nim [10.1.1.114] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /home/root/.ssh/identity type -1
debug1: identity file /home/root/.ssh/id_rsa type -1
debug1: identity file /home/root/.ssh/id_dsa type 2
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2
debug1: match: OpenSSH_5.2 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 't1was1_nim' is known and matches the RSA host key.
debug1: Found key in /home/root/.ssh/known_hosts:79
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received

I have not changed anything in these machines. This is just a sudden
move. These servers are on AIX.

--
Kosala
--------------------------------------------
Disclaimer: Views expressed in this mail are my personal views and
they would not reflect views of the employer.
--------------------------------------------
blog.kosala.net
www.linux.lk/~kosala/
www.kosala.net



Relevant Pages

  • Re: delay after sshing into a server
    ... Also, they are the same as the same files on the other servers, and those servers don't have this problem. ... debug1: Connecting to aa port 22. ... there is a 30 second delay before I get the password prompt. ...
    (RedHat)
  • Re: delay after sshing into a server
    ... Also, they are the same as the same files on the other servers, and those servers don't have this problem. ... debug1: Connecting to aa port 22. ... there is a 30 second delay before I get the password prompt. ...
    (RedHat)
  • Re: delay after sshing into a server
    ... those servers don't have this problem. ... try ssh -vv user@wherever to see where the hang is happening. ... debug1: Connecting to aa port 22. ... I then restarted network just to make sure the hosts file ...
    (RedHat)
  • Re: delay after sshing into a server [SOLVED]
    ... Also, they are the same as the same files on the other servers, and those servers don't have this problem. ... debug1: Connecting to aa port 22. ... I then restarted network just to make sure the hosts file was reread. ... It was the USERID on the log_on_success line that was causing the problem. ...
    (RedHat)
  • Re: delay after sshing into a server
    ... Also, they are the same as the same files on the other servers, and those servers don't have this problem. ... debug1: Connecting to aa port 22. ... I then restarted network just to make sure the hosts file was reread. ... There is still a 30 second delay. ...
    (RedHat)