RE: SSH connection glitch.



Can you ssh locally to itself? Can you setup another sshd server on
another port running in debug mode?

Jason

-----Original Message-----
From: listbounce@xxxxxxxxxxxxxxxxx [mailto:listbounce@xxxxxxxxxxxxxxxxx]
On Behalf Of Warren Halstead
Sent: Monday, March 22, 2010 7:58 AM
To: secureshell@xxxxxxxxxxxxxxxxx
Subject: SSH connection glitch.

Setup:
Debian 5.0.4 setup in VMWare
OpenSSL 0.9.8m compiled from source
OpenSSH 5.4p1 compiled from source

Problem:
I CAN connect (in my lab) to the VM through puTTY.
I CAN connect (in my lab) to the VM from another VM. (A cloned copy of
the first one.)
I CAN connect to the VM from another VM with the bandwidth
artificially turned town to 765 kilobits (yes, bits) per sec and
1000ms latency.

I sent a copy of the VM to a US military unit in another country to
test it out.....and I can NOT connect...kinda.

It connects. It runs through the WHOLE handshake and then stalls at
this debug message:

SSH2_MSG_SERVICE_ACCEPT

....it then hangs.

The sysadmin at the other end can connect to the VM with puTTY. We
just can't connect from here to there.

Any idea? I already turned off UseDNS in sshd_config.

Wireshark shows no continuing traffic.

Is there anything else I can do to troubleshoot this further?

Thanks in advance.

~Warren

NOTICE - This message and any attached files may contain information that is confidential and/or subject of legal privilege intended only for use by the intended recipient. If you are not the intended recipient or the person responsible for delivering the message to the intended recipient, be advised that you have received this message in error and that any dissemination, copying or use of this message or attachment is strictly forbidden, as is the disclosure of the information therein. If you have received this message in error please notify the sender immediately and delete the message.