Re: authenticated, but no prompt



Hello Sharad and others,

you made my day! i already tried to do ssh as root with the 'reboot'
command, but it didn't work. however when i tried it again with '-T', i
was able to reboot the machine and now i can login again. Still have to
look for the real cause. Anyway, thank you very much!

dirk

On Tue, 2009-07-21 at 09:35 +0530, Sharad wrote:
Do you check if ssh hostname somecommand works or not? Try to run it with terminal suppression using -T i.e. ssh -T hostname somecommand.

If that works perhaps something wrong with the terminal allocation on the remote side (may they are all utilized? just guessing!) or problem with the shell.

Sharad
--- On Sat, 18/7/09, dirk ooms <dirk@xxxxxxxxxxxxxx> wrote:

From: dirk ooms <dirk@xxxxxxxxxxxxxx>
Subject: authenticated, but no prompt
To: secureshell@xxxxxxxxxxxxxxxxx
Date: Saturday, 18 July, 2009, 12:22 AM
Hello,

until this morning I was able to ssh from my ubuntu client
to my fedora
core 9 server. suddenly (without any config change on the
server or the
client), I couldn't ssh anymore: I could still enter the
password,
authentication seems to be ok, but no shell prompt :-(

so I am wondering what's going on here. since it is
difficult to
physically access the machine, I would be very happy to
receive a
suggestion for a workaround.

below is the last part of the ssh -vvv output (I replaced
the real
machine name by mymachine.mydomain)

I can still ssh to other servers from my client.

cheers,
dirk

debug1: Next authentication method: password
dirk@xxxxxxxxxxxxxxxxxx's
password:
debug3: packet_send2: adding 64 (len 58 padlen 6 extra_pad
64)
debug2: we sent a password packet, wait for reply
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Entering interactive session.
debug1: channel 0: free: client-session, nchannels 1
debug3: channel 0: status: The following connections are
open:
#0 client-session (t3 r-1 i0/0 o0/0 fd 4/6 cfd -1)

debug3: channel 0: close_fds r 4 w 6 e 7 c -1
Read from remote host mymachine.mydomain: Connection reset
by peer
Connection to mymachine.mydomain closed.
debug1: Transferred: stdin 0, stdout 0, stderr 110 bytes in
0.0 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr
4537.2
debug1: Exit status -1





Yahoo! recommends that you upgrade to the new and safer Internet Explorer 8. http://downloads.yahoo.com/in/internetexplorer/




Relevant Pages

  • LDAP Authentication via SSH
    ... authenticate via SSH to the LDAP server. ... debug1: Connecting to ldapclient.domain port 22. ... debug1: Next authentication method: keyboard-interactive ... # rlogin service (explicit because of pam_rhost_auth) ...
    (SunManagers)
  • Help request: problems with a 5.1 server and large numbers of ssh users.
    ... FreeBSD 5.1 because I need to be able to support ldap authentication.) ... My version of ssh is 3.6.1p2 patched to address the security concerns. ... debug1: Rhosts Authentication disabled, ... debug1: Connection established. ...
    (freebsd-current)
  • Help request: problems with a 5.1 server and large numbers of ssh users.
    ... FreeBSD 5.1 because I need to be able to support ldap authentication.) ... My version of ssh is 3.6.1p2 patched to address the security concerns. ... debug1: Rhosts Authentication disabled, ... debug1: Connection established. ...
    (freebsd-hackers)
  • Problems with passwordless ssh/scp (W2K client , Solaris 8 server).
    ... configuration for the ssh client and server. ... The SSH server configuration is a pretty standard configuration (Solaris ... Rhosts Authentication disabled, ... debug1: Connection established. ...
    (SSH)
  • RE: RE : RE : X11Forwarding problem on Solaris.
    ... The program is using the display environment variable. ... First i use ssh to connect from node2 to node4 and then I start the PROGRAM ... debug1: Connection established. ... Subject: RE: RE: X11Forwarding problem on Solaris. ...
    (SSH)