OpenSSH's sshd drops connections



Hello,

I manage around 50 FreeBSD servers and I have created a script which does
some work every 5 minutes. Actually this script transfers some files to/from
the central server, which is running a OpenSSH's sshd
(OpenSSH_4.5p1 FreeBSD-20061110, OpenSSL 0.9.7e-p1 25 Oct 2004). So I use
sftp (I have also tried scp) on client sides to perform the task.

The problem is, that (apparently because all the servers start transferring
files at approximately the same time), some clients are able to do the transfers
and others are not.

If the connection is unsuccessful, I get this on client side (sftp -v):

Connecting to a.b.c.d...
OpenSSH_4.2p1 FreeBSD-20050903, OpenSSL 0.9.7e-p1 25 Oct 2004
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to a.b.c.d [a.b.c.d] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/id_rsa type 1
debug1: identity file /root/.ssh/id_dsa type -1
ssh_exchange_identification: Connection closed by remote host
Connection closed

So it looks like sshd on the central server just drops the connection. I have
also tried to turn on DEBUG mode for sshd on central server, but there is way
too much of the output to analyze. I've grepped (-i) the log file for the word
"error" but no lines matched.

If the connection is successful, however, I get this on client side:

Connecting to a.b.c.d...
OpenSSH_4.2p1 FreeBSD-20050903, OpenSSL 0.9.7e-p1 25 Oct 2004
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to a.b.c.d [a.b.c.d] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/id_rsa type 1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.5p1 FreeBSD-20061110
debug1: match: OpenSSH_4.5p1 FreeBSD-20061110 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.2p1 FreeBSD-20050903
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'a.b.c.d' is known and matches the DSA host key.
debug1: Found key in /root/.ssh/known_hosts:30
debug1: ssh_dss_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering public key: /root/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 277
debug1: read PEM private key done: type RSA
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending subsystem: sftp
sftp> get file1 file2
Fetching file1 to file2
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: free: client-session, nchannels 1
debug1: fd 0 clearing O_NONBLOCK
debug1: fd 2 clearing O_NONBLOCK
debug1: Transferred: stdin 0, stdout 0, stderr 0 bytes in 0.4 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.0
debug1: Exit status 0

Do you have any ideas why the central server's sshd drops the connections?
It's a modern machine with a good network card on a fast link, so this
should not be a problem. Also, before I used plain FTP and HTTP transfers
and everything worked OK.

Thanks,
Nejc



Relevant Pages

  • Non root scp problem
    ... This is a production web server and the webmaster uses a non-root account to copy files constantly. ... debug1: Connecting to ares port 22. ... invalid collation element ...
    (SSH)
  • interactive commands via plink.exe -> linux/sshd
    ... putty/PLINK to push the backup data to the server via rsync. ... connection just seems to die as if the client cancelled the connection, ... debug1: read PEM private key done: type RSA ...
    (comp.security.ssh)
  • ssh connection pause
    ... I'm having a strange issue where establishing an SSH connection to an AIX ... box running openssh v4.6 pauses for approximately 30 seconds during the ... debug1: Connection established. ... Server listening on 0.0.0.0 port 22. ...
    (SSH)
  • Ora-rg could not start using scswitch command!
    ... So oracle server could not be started. ... Is Shockwave Plugin available for Solaris??? ... debug1: read PEM private key done: type RSA ...
    (SunManagers)
  • ssh from solaris8 to win2000 no work.
    ... Im running openssh on solaris8 and commercial sshd on win2000, ... debug1: Rhosts Authentication disabled, ... debug1: Connection established. ... 2588:WARNING: Server became zombie - must commit suicide. ...
    (SunManagers)