Pubic key with proxy command



Hi,

I'm getting following message when connecting to a external sftp server by public key authendication and through a ssh proxy.

(pmart8d@chidevs01d:inft) /opt/app/pmart8d/.ssh $sftp -vvv -F /opt/app/pmart8d/.ssh/ssh_config -o stricthostkeychecking=no 207.106.160.143
Connecting to 207.106.160.143...
OpenSSH_4.3p2, OpenSSL 0.9.8a 11 Oct 2005
debug1: Reading configuration data /opt/app/pmart8d/.ssh/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Executing proxy command: exec connect -ddd -H http-proxy-ssh.amer.consind.ge.com:8080 207.106.160.143 22
debug3: Not a RSA1 key file /opt/app/pmart8d/.ssh/mmax.dsa.
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug3: key_read: missing keytype
debug2: key_type_from_name: unknown key type 'Proc-Type:'
debug3: key_read: missing keytype
debug2: key_type_from_name: unknown key type 'DEK-Info:'
debug3: key_read: missing keytype
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug2: key_type_from_name: unknown key type '-----END'
debug3: key_read: missing keytype
debug1: identity file /opt/app/pmart8d/.ssh/mmax.dsa type 2
DEBUG: No direct address are specified.
DEBUG: relay_method = HTTP (3)
DEBUG: relay_host=http-proxy-ssh.amer.consind.ge.com
DEBUG: relay_port=8080
DEBUG: relay_user=pmart8d
DEBUG: local_type=stdio
DEBUG: dest_host=207.106.160.143
DEBUG: dest_port=22
DEBUG: Program is $Revision: 1.96 $
DEBUG: not matched, addr to be SOCKSified: 207.106.160.143
DEBUG: resolving host by name: http-proxy-ssh.amer.consind.ge.com
DEBUG: resolved: http-proxy-ssh.amer.consind.ge.com (3.130.230.100)
DEBUG: connecting to 3.130.230.100:8080
DEBUG: begin_http_relay()
DEBUG: >>> "CONNECT 207.106.160.143:22 HTTP/1.0\r\n"
DEBUG: >>> "\r\n"
DEBUG: <<< "HTTP/1.0 200 Connection established\r\n"
DEBUG: connected, start user session.
DEBUG: <<< "\r\n"
DEBUG: connected
DEBUG: start relaying.
DEBUG: connection closed by peer
DEBUG: relaying done.
DEBUG: that's all, bye.
ssh_exchange_identification: Connection closed by remote host
Connection closed

My ssh_config file is this
ProxyCommand connect -ddd -H http-proxy-ssh.amer.consind.ge.com:8080 %h %p
ForwardX11 yes
ForwardAgent yes
IdentityFile ~/.ssh/mmax.dsa
#PasswordAuthentication yes
Protocol 2

What is the problem why it "debug3: Not a RSA1 key"
Some one please try to clarify me.

I'm using OpenSSH_4.3p2, OpenSSL 0.9.8a...

--balaji mariyappan


Thanks & Regards,
Balaji Mariyappan
GE Equipment services
Desk: 312.853.5056
Mobile: 312.213.7112



Relevant Pages

  • RE: Determine forwarded ports?
    ... DEBUG: ... debug3: key_read: missing whitespace ... debug1: Remote protocol version 2.0, remote software version 3.2.9 SSH Secure Shell Windows NT Server ...
    (SSH)
  • Weird SSH issue.
    ... I'm having trouble connecting to any server outside my local ... debug3: key_read: missing keytype ... debug3: key_read: missing whitespace ...
    (SSH)
  • Re: Cannot deploy or debug with VS2005 or VS2005
    ... debug) I have been doing device development for 5 years now and while i had ... my share of device not connecting and similar things nothing like this ... "BlackMDK" wrote: ... im thinkimg that ther is problem with windows registry but who knows. ...
    (microsoft.public.dotnet.framework.compactframework)
  • Re: Slow connecting process
    ... > that long to time out on the reverse DNS lookup. ... I am connecting by IP-Adress, so how is DNS needed in this process? ... debug: SshAppCommon/sshappcommon.c:154: Allocating global SshRegex ... server offers auth methods 'publickey,password'. ...
    (comp.security.ssh)
  • Re: Hosting Remoting in IIS
    ... There's not much you can do to "debug" this problem, ... connecting to your service in the first place. ... then try pointing your web browser to the relevant .rem file (and maybe try ... than "Requested Service Not Found", like another error, or whatever, then ...
    (microsoft.public.dotnet.framework.remoting)