Re: X11 tuneling: a hard to fix problem




Ok i ran `sshd -ddd` following the suggestion of Jonathan Loh:

Then local.client.desktop# xterm
. . .
. . .
. . .
debug1: session_input_channel_req: session 0 req x11-req
debug2: bind port 6010: Cannot assign requested address
debug1: channel 1: new [X11 inet listener]
debug1: server_input_channel_req: channel 0 request pty-req reply 0
debug1: session_by_channel: session 0 channel 0
debug1: session_input_channel_req: session 0 req pty-req
debug1: Allocating pty.
debug1: session_new: init
debug1: session_new: session 0
. . .
. . .
. . .
. . .
And now it goes

For some reason the DISPLAY variable was set to localhost:11.0.
Now i stop && start the sshd and it always forwards DISPLAY
correctly, without changing any config file.

I know we get lasy to understand a problem once we solved it
without understanding, but i these case I'd like to know it
anyone has an idea what happened.
The `ssh -vvv remote.server` shows the same messages as before.

For some reason the remote.server was not getting the conection
to port 6010, as seen above. But know it gets !!! ???

Thanks all for the help,
nader



Relevant Pages

  • Re: McAfee and CygWin SSH
    ... Try it with sshd -d and see what it says -- perhaps something is ... debug1: sshd version OpenSSH_4.3p2 ... debug1: read PEM private key done: type RSA ...
    (comp.security.ssh)
  • Sun SSH IPv6 and X11 Problem
    ... I am having a problem with the Sun SSH delivered with Solaris 9. ... Running the server in debug mode makes it clear ... debug1: Server will not fork when running in debugging mode. ... debug1: bind port 6010: Address already in use ...
    (SunManagers)
  • Re: Help setting up sshd, please
    ... I'm trying to get sshd working on an embryonic Gentoo installation. ... I've run sshd as sshd -d, which puts debugging info onto the screen. ... debug1: userauth-request for user root service ssh-connection method ... then you're on the installation media's kernel still. ...
    (comp.os.linux.setup)
  • Re: Cant login to an OS X box using ssh
    ... using sshd -d which seems to be more helpful than ssh -d5 or any level ... verbose mode on the client side. ... debug1: read PEM private key done: type RSA ... SSH Secure Shell ...
    (comp.security.ssh)
  • Re: SSH not working
    ... debug1: sshd version OpenSSH_3.6.1p2 ... debug1: read PEM private key done: type RSA ... RSA key generation complete. ...
    (alt.os.linux)