Re: SCO OpenServer 5.0.5 authenticates locked accounts


How about using PAM ? I'm not sure if SCO OpenServer 5.0.5 has PAM support.

Powell, Scott wrote:
I have noticed that SSH compiled for SCO OpenServer 5.0.5 is
authenticating locked accounts. I have tried re-compiling the latest
portable version, 4.3p2, as well as some older versions. I also tried a
Skunkware version supplied by SCO. All of these are authenticating
locked accounts. I even messed around in and added
AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") to the *-*-sco3.2v5* definitions
(locked accounts have a *LK* in the shadow file as a prefix to the
encrypted password hash.

Does anyone have any recommendations or workarounds?


Relevant Pages