Compiling troubles on linux

je_ossh_at_kronos.honk.org
Date: 02/15/05

  • Next message: Jason Joines: "StrictHostKeyChecking=no seems to have no affect"
    Date: Tue, 15 Feb 2005 16:19:59 -0500 (EST)
    To: secureshell@securityfocus.com
    
    

    Hello,

    Trying to compile openssh-3.9p1 on Linux with OpenSSL 0.9.7f-dev, built
    with shared libs.

    If I try to configure openssh with the system's standard SSL libs, no
    problem. If I try to configure it using a statically compiled openssl
    0.9.7f-dev, no problem. However, if I try to configure against 0.9.7f-dev
    built with the 'shared' commandline option, I get the following error:

    # ./configure \
    --prefix=/usr/tools/openssh \
    --with-ssl-dir=/usr/tools/openssl \
    --with-privsep-path=/usr/tools/openssh/empty \
    --without-pam \
    --without-zlib-version-check
    ...
    checking OpenSSL header version... not found
    configure: error: OpenSSL version header not found.

    Only diff is the libs used:

    # ls -l /usr/tools/openssl.old/lib/ /usr/tools/openssl/lib/
    /usr/tools/openssl/lib/:
    total 3512
    -rw-r--r-- 1 root root 1891278 Feb 15 14:30 libcrypto.a
    lrwxrwxrwx 1 root root 14 Feb 15 14:30 libcrypto.so ->
    libcrypto.so.0
    lrwxrwxrwx 1 root root 18 Feb 15 14:30 libcrypto.so.0 ->
    libcrypto.so.0.9.7
    -r-xr-xr-x 1 root root 1169215 Feb 15 14:30 libcrypto.so.0.9.7
    -rw-r--r-- 1 root root 293616 Feb 15 14:30 libssl.a
    lrwxrwxrwx 1 root root 11 Feb 15 14:30 libssl.so ->
    libssl.so.0
    lrwxrwxrwx 1 root root 15 Feb 15 14:30 libssl.so.0 ->
    libssl.so.0.9.7
    -r-xr-xr-x 1 root root 214271 Feb 15 14:30 libssl.so.0.9.7
    drwxrwxr-x 2 root root 4096 Feb 15 14:30 pkgconfig

    /usr/tools/openssl.old/lib/:
    total 2048
    -rw-r--r-- 1 root root 1800674 Dec 24 12:55 libcrypto.a
    -rw-r--r-- 1 root root 280584 Dec 24 12:55 libssl.a
    drwxr-xr-x 2 root root 4096 Dec 16 10:24 pkgconfig

    OpenSSL is built as follows:

    ./config --openssldir=/usr/tools/openssl \
        no-threads \
        no-zlib \
        no-krb5 \
        no-rc5 \
        no-idea shared
    make depend; make; make install

    Any thoughts?

    Cheers!
    Jon

    -- 
    Jon Earle
    Software Developer / Network Manager
    Specializing in Open Source Software Solutions
    http://kronos.honk.org/~earlej/
    

  • Next message: Jason Joines: "StrictHostKeyChecking=no seems to have no affect"

    Relevant Pages

    • Re: Mosaic v3.9 compile
      ... I recently built Mosaic 3.9 with SSL support. ... TCP/IP specified. ... with OpenSSL built this way that https urls do not work. ... that Lynx needs OpenSSL to be built with the same TCP/IP package ...
      (comp.os.vms)
    • FC2 and OpenSSL 0.9.7e
      ... Needing some of the features of the current release of OpenSSL 0.9.7e, ... I can get this built but I ... related to Fedora and newer OpenSSL releases. ... own RPM since it's out of date. ...
      (Fedora)
    • Re: Setup UW IMAP server with existing mailbox files
      ... This imapd binary is build with OpenSSL and mandatory encryption. ... Either you built with OpenSSL, even though you said that you did not do so, or the binary that xinetd starts is a different binary. ... Install a binary that is built without OpenSSL ...
      (comp.mail.imap)
    • Re: Mosaic v3.9 compile
      ... TCP/IP specified. ... with OpenSSL built this way that https urls do not work. ... that Lynx needs OpenSSL to be built with the same TCP/IP package ...
      (comp.os.vms)
    • security/openssl speed issues
      ... Now, I'm trying to measure the impact of said AES extentions, I tumbled on a very weird difference in behaviour between our base system openssl and the one in ports. ... The one is base is not supposed to have cryptodev (and aesni) support at all as it was added apparently in 1.0.1. ... built on: Sun Jul 28 16:36:48 CEST 2013 ...
      (FreeBSD-Security)