ssh works through ppp0, not through ADSL router

From: M. Fioretti (mfioretti_at_mclink.it)
Date: 05/14/04

  • Next message: Jeremy Lin: "Re: Problem running remote app with ssh"
    Date: Fri, 14 May 2004 23:01:36 +0200
    To: secureshell@securityfocus.com
    
    

    Hello,

    I run openssh-3.5p1-6 on Red Hat 9 to connect to a server to update
    its web pages. If I connect via dialup / ppp0 is OK. If I try the same
    thing connecting via etho to an ADSL router:

    I can ping the server
    I can browse its web pages
    the isp doesn't block any port

    but ssh times out after asking the password. I tried to ssh to another
    server: I got the message saying (after my confirmation) that that
    host had been added to ~/.ssh/hosts, so it seems to me that ssh port
    is not being blocked. Or is it? What could it be, and how could I
    figure it out?

    Using ssh -v -v -v user@remote.ssl.host.tld yelds a long log which
    ends as below after I enter the password. Any further feedback is
    welcome.

    TIA,
            Marco Fioretti

    debug2: we sent a keyboard-interactive packet, wait for reply
    debug1: authentications that can continue:
    publickey,password,keyboard-interacti
    ve
    debug3: userauth_kbdint: disable: no info_req_seen
    debug2: we did not send a packet, disable method
    debug3: authmethod_lookup password
    debug3: remaining preferred:
    debug3: authmethod_is_enabled password
    debug1: next auth method to try is password
    <MY_ACCOUNT>@<MY_SERVER>'s password:
    debug3: packet_send2: adding 48 (len 64 padlen 16 extra_pad 64)
    debug2: we sent a password packet, wait for reply
    debug1: ssh-userauth2 successful: method password
    debug1: channel 0: new [client-session]
    debug3: ssh_session2_open: channel_new: 0
    debug1: send channel open 0
    debug1: Entering interactive session.
    debug2: callback start
    debug1: ssh_session2_setup: id 0
    debug1: channel request 0: pty-req
    debug3: tty_make_modes: ospeed 38400
    debug3: tty_make_modes: ispeed 38400
    debug3: tty_make_modes: 1 3
    debug3: tty_make_modes: 2 28
    debug3: tty_make_modes: 3 127
    debug3: tty_make_modes: 4 21
    debug3: tty_make_modes: 5 4
    debug3: tty_make_modes: 6 0
    debug3: tty_make_modes: 7 0
    debug3: tty_make_modes: 8 17
    debug3: tty_make_modes: 9 19
    debug3: tty_make_modes: 10 26
    debug3: tty_make_modes: 12 18
    debug3: tty_make_modes: 13 23
    debug3: tty_make_modes: 14 22
    debug3: tty_make_modes: 18 15
    debug3: tty_make_modes: 30 0
    debug3: tty_make_modes: 31 0
    debug3: tty_make_modes: 32 0
    debug3: tty_make_modes: 33 0
    debug3: tty_make_modes: 34 0
    debug3: tty_make_modes: 35 0
    debug3: tty_make_modes: 36 1
    debug3: tty_make_modes: 37 0
    debug3: tty_make_modes: 38 1
    debug3: tty_make_modes: 39 0
    debug3: tty_make_modes: 40 0
    debug3: tty_make_modes: 41 0
    debug3: tty_make_modes: 50 1
    debug3: tty_make_modes: 51 1
    debug3: tty_make_modes: 52 0
    debug3: tty_make_modes: 53 1
    debug3: tty_make_modes: 54 1
    debug3: tty_make_modes: 55 1
    debug3: tty_make_modes: 56 0
    debug3: tty_make_modes: 57 0
    debug3: tty_make_modes: 58 0
    debug3: tty_make_modes: 59 1
    debug3: tty_make_modes: 60 1
    debug3: tty_make_modes: 61 1
    debug3: tty_make_modes: 62 0
    debug3: tty_make_modes: 70 1
    debug3: tty_make_modes: 71 0
    debug3: tty_make_modes: 72 1
    debug3: tty_make_modes: 73 0
    debug3: tty_make_modes: 74 0
    debug3: tty_make_modes: 75 0
    debug3: tty_make_modes: 90 1
    debug3: tty_make_modes: 91 1
    debug3: tty_make_modes: 92 0
    debug3: tty_make_modes: 93 0
    debug2: x11_get_proto: /usr/X11R6/bin/xauth list :0.0 2>/dev/null
    debug1: Requesting X11 forwarding with authentication spoofing.
    debug1: channel request 0: x11-req
    debug1: channel request 0: shell
    debug1: fd 3 setting TCP_NODELAY
    debug2: callback done
    debug1: channel 0: open confirm rwindow 0 rmax 32768
    debug1: Remote: No xauth program; cannot forward with spoofing.
    debug2: client_check_window_change: changed
    debug1: channel request 0: window-change
    debug1: channel_free: channel 0: client-session, nchannels 1
    debug3: channel_free: status: The following connections are open:
      #0 client-session (t4 r0 i0/0 o0/0 fd 4/5)

    debug3: channel_close_fds: channel 0: r 4 w 5 e 6
    Read from remote host <MYSERVER>: Connection timed out
    Connection to <MYSERVER> closed.
    debug1: Transferred: stdin 0, stdout 0, stderr 116 bytes in 1750.1
    seconds
    debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.1
    debug1: Exit status -1

    -- 
    Marco Fioretti                 m.fioretti, at the server inwind.it
    Red Hat for low memory         http://www.rule-project.org/en/
    THERE IS NO AMOUNT OF SUCCESS THAT CAN COMPENSATE FOR FAILURE
    AT HOME.
    

  • Next message: Jeremy Lin: "Re: Problem running remote app with ssh"