ClientAliveInterval not working?

From: Joe Terwilliger (jterwilliger_at_ewess.com)
Date: 10/06/03

  • Next message: John Howell: "Re: ssh session exits after authentication"
    To: <secureshell@securityfocus.com>
    Date: Mon, 6 Oct 2003 12:37:23 -0400
    
    

    Hello,

    This is my first time to the list, I apologize beforehand if I have missed
    anything in the FAQ on this. Any suggestions or pointers to links would be
    helpful. I've done the traditional multi-google search and havent come up
    with a solution yet.

    We are trying to control inactivity timeout on sshd using the
    ClientAliveInterval and ClientAliveCountMax sshd_config settings but it
    doesnt seem to be having any affect on timing out and disconnecting
    inactive/idle clients. I have tried using standard numeric arguments and
    numeric arguments followed by a character modifier (s, m, h, etc) with no
    effect. Clients are still staying connected regardless of the
    ClientAliveInterval setting and what client I am using to connect - I have
    tried PuTTY and the standards ssh clients to connect, both with keepalive
    settings turned off. Are there issues with this feature in openSSH or
    something I am missing in the documentation?

    Thanks in advance,

    Joe T


  • Next message: John Howell: "Re: ssh session exits after authentication"

    Relevant Pages

    • ICS and Proxy Settings
      ... Is there any way using ICS to tell its DHCP clients what proxy settings to ... I have 2-way satellite internet access at home (via ...
      (microsoft.public.windowsxp.general)
    • Re: W2K3 GPO pushing IE settings to W2K...
      ... > We have a setup using a W2K3 AD server pushing the GPO out to a fleet ... > The problem is that not ~all~ the settings seem to be pushed. ... > and changed like I'd expect, reflecting what's in the GPO. ... The settings nor the site list appear on the clients. ...
      (microsoft.public.windows.server.setup)
    • RE: Time Service Questions
      ... and time sync clients like XP or w2K pro... ... You might want to check out the section specifically on Time Service ... settings and tools to locate the infor you are looking for. ... > have time service registry keys that look like this... ...
      (microsoft.public.win2000.active_directory)
    • RE: Win2K3 PDC not acting as time server
      ... First are all the DCs in Default_First_site_name site? ... subnet in Windows Server 2003 Active Directory? ... Based on the registry settings, the clients is use NTP as time ...
      (microsoft.public.windows.server.migration)
    • Re: Proxy Settings
      ... Unfortunatly there is no common theme, it is happening on win2K and XP clients. ... The support site looks you directed me to does look useful though, ... It only applies when the policy changes or is ... >> to be picking up the policy but the proxy settings are not being set. ...
      (microsoft.public.win2000.group_policy)