Re: new openssh on openbsd 3.2

From: Mac Schwarz (
Date: 09/19/03

  • Next message: Hong Tian: "RE: Openssh 3.7p1 Solaris Compile"
    Date: Fri, 19 Sep 2003 12:21:35 +0200

    Roelf Schreurs wrote:

    > Hi
    > I get the following error when trying to upgrade openssh to 3.7.1 by doing:
    > # cd /usr/src/usr.bin
    > # tar xvfz .../openssh-x.y.tgz
    > # cd ssh
    > # make obj
    > # make cleandir
    > # make depend
    > # make

    You need to apply the patch
    prior to building openssh.

    Have a look at

    "If you are installing OpenSSH 3.7.1 on OpenBSD 3.3 or older, you need
    the following patch"

    But there's another thing that's puzzling me: Which location in the fs
    should .../ be? . is current directory and .. is parent directory. But
    where's ...? I thought this was a typo after seeing it on the openssh
    webpage first but it seems not to be.


  • Next message: Hong Tian: "RE: Openssh 3.7p1 Solaris Compile"

    Relevant Pages

    • openssh3.5p1: new functionality added, modifications done
      ... This is NOT an official or unofficial openssh announcement, patch, release ... secure ftp services for our web content developers. ... there is no server-side control over umask and file permissions. ... I'm running openssh with my patch on my servers, and am quite happy with it. ...
    • SUMMARY: Trouble last after SSH + LDAP
      ... As it turned out this is an issue with OpenSSH 4.3p1. ... Did a make distclean, applied the patch, and rebuilt with no problems. ... authentication against an OpenLDAP server. ... PAM LDAP module 1.80 ...
    • [UNIX] OpenSSH IP Restriction Bypass (adv.option, Patch Available)
      ... OpenSSH IP Restriction Bypass ... Apply the following patch. ... The information in this bulletin is provided "AS IS" without warranty of any kind. ... In no event shall we be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. ...
    • Re: sshd, sftp & umask settings ( 2.4.0)
      ... This is a problem with openssh as well. ... I just posted this patch a few minutes ago. ... > I found that's sshd has a configuration option to use the umask ... > setting in the .cshrc file by setting the following in ...
    • Re: AIX patch works for Openssh but not Putty
      ... >>I have applied a patch to openssh to get it working with AIX password ... If I ssh to the daemon using openssh ssh it works fine. ... > As far as I know PuTTY does not handle PASSWD_CHANGEREQ. ...