SSH 3.2.3 - Problem executing Make

From: James (james00_c@yahoo.com)
Date: 03/13/03

  • Next message: Gaude, Joseph: "INstall troubles..."
    Date: Wed, 12 Mar 2003 18:07:47 -0800 (PST)
    From: James <james00_c@yahoo.com>
    To: secureshell@securityfocus.com
    
    

    I am trying to compile the non-commerical version of
    SSH 3.2.3 under AIX 4.3 and receiving the following
    messages:

    $ make (i.e. /usr/local/bin/make)
    exec(): 0509-036 Cannot load program make because of
    the following errors:
        0509-130 Symbol resolution failed for make
    because:
        0509-136 Symbol stpcpy (number 101) is not
    exported from dependent module /usr/lib/libc.a(shr.o).
        0509-136 Symbol strsignal (number 102) is not
    exported from dependent module /usr/lib/libc.a(shr.o).
        0509-192 Examine .loader section symbols with the
                     'dump -Tv' command.

    or

    $ /usr/ccs/bin/make
            cd . && CONFIG_FILES=
    CONFIG_HEADERS=sshconf.h /bin/sh
    ./config.status
    creating sshconf.h
    sshconf.h is unchanged
            make all-recursive
    exec(): 0509-036 Cannot load program make because of
    the following
    errors:
        0509-130 Symbol resolution failed for make
    because:
        0509-136 Symbol stpcpy (number 101) is not
    exported from dependent module /usr/lib/libc.a(shr.o).
        0509-136 Symbol strsignal (number 102) is not
    exported from dependent module /usr/lib/libc.a(shr.o).
        0509-192 Examine .loader section symbols with the
                     'dump -Tv' command.
    make: 1254-004 The error code from the last command is
    255.

    Stop.
    ---------------

    Before the "make" I can successfully run the
    ./configure command and the summary displayed is as
    follows:

      Host type................: powerpc-ibm-aix4.3.2.0
      CC.......................: gcc
      CPPFLAGS.................:
      CFLAGS...................: -g -O2 -Wall
    -Wno-unknown-pragmas -D_LARGE_FILES
      LDFLAGS..................:
      LIBS.....................: -lm -lbsd -lnsl -ls
    -lxcurses -ltermcap -lnsl -L/usr/local/lib
      X includes...............: NO
      X libraries..............:

      Debug enabled............: light
      IPv6 support.............: yes
      RSA support..............: yes
      SSH1 internal emulation..: yes
      SSH1 fallback capability.: yes
      Kbd-interactive in server: yes
        Submethods.............: passwd plugin
      Kbd-interactive in client: yes
      PAM support in server....: no
      PAM support in client....: yes
      SecurID support in server: no
      SecurID support in client: yes
      Kerberos5 support........: no
      TCP Wrappers support.....: no
      Terminal capability lib..: terminfo
      X11 SECURITY extension...: no

      PTY Type.................: pts

      Installation prefix......: /usr/local
      bin directory............: /usr/local/bin
      sbin directory...........: /usr/local/sbin
      man directory............: /usr/local/man
      ssh2 etc directory.......: /etc/ssh2
      PID-file directory.......: default

    I have also tried "./configure --enable-static" and
    this didn't help either. A bug report to SSH was
    submitted a few days back but since this is a
    non-commerical version, I do not expect to hear from
    them. Any tips on how to remedy this problem?
    Thanks!

    James

    __________________________________________________
    Do you Yahoo!?
    Yahoo! Web Hosting - establish your business online
    http://webhosting.yahoo.com


  • Next message: Gaude, Joseph: "INstall troubles..."