[NT] Cumulative Security Update for Internet Explorer (MS08-045)



The following security advisory is sent to the securiteam mailing list, and can be found at the SecuriTeam web site: http://www.securiteam.com
- - promotion

The SecuriTeam alerts list - Free, Accurate, Independent.

Get your security news from a reliable source.
http://www.securiteam.com/mailinglist.html

- - - - - - - - -



Cumulative Security Update for Internet Explorer (MS08-045)
------------------------------------------------------------------------


SUMMARY

This security update resolves five privately reported vulnerabilities and
one publicly disclosed vulnerability. All of the vulnerabilities could
allow remote code execution if a user views a specially crafted Web page
using Internet Explorer. Users whose accounts are configured to have fewer
user rights on the system could be less impacted than users who operate
with administrative user rights.

This security update is rated Critical for all supported releases of
Internet Explorer. For more information, see the subsection, Affected and
Non-Affected Software, in this section.

DETAILS

Affected Software:
* Internet Explorer 5.01 and Internet Explorer 6 Service Pack 1
* Microsoft Windows 2000 Service Pack 4 -
<http://www.microsoft.com/downloads/details.aspx?familyid=1557B93B-ECBA-4F42-B89D-DB0EE067D65B> Microsoft Internet Explorer 5.01 Service Pack 4 - Remote Code Execution - Critical - MS08-031
* Microsoft Windows 2000 Service Pack 4 -
<http://www.microsoft.com/downloads/details.aspx?familyid=AA780735-5928-4C46-89A4-63A814954796> Microsoft Internet Explorer 6 Service Pack 1 - Remote Code Execution - Critical - MS08-031
* Internet Explorer 6
* Windows XP Service Pack 2 -
<http://www.microsoft.com/downloads/details.aspx?familyid=69AF2F30-138E-4B15-AB8D-4FCE44CC0BC2> Microsoft Internet Explorer 6 - Remote Code Execution - Critical - MS08-031
* Windows XP Service Pack 3 -
<http://www.microsoft.com/downloads/details.aspx?familyid=69AF2F30-138E-4B15-AB8D-4FCE44CC0BC2> Microsoft Internet Explorer 6 - Remote Code Execution - Critical - MS08-031
* Windows XP Professional x64 Edition and Windows XP Professional x64
Edition Service Pack 2 -
<http://www.microsoft.com/downloads/details.aspx?familyid=4780B89E-9735-4D3F-8DEF-34E7337FF604> Microsoft Internet Explorer 6 - Remote Code Execution - Critical - MS08-031
* Windows Server 2003 Service Pack 1 and Windows Server 2003 Service Pack
2 -
<http://www.microsoft.com/downloads/details.aspx?familyid=0617A5DD-DCE9-4DE0-B0A0-CE38EFE13524> Microsoft Internet Explorer 6 - Remote Code Execution - Critical - MS08-031
* Windows Server 2003 x64 Edition and Windows Server 2003 x64 Edition
Service Pack 2 -
<http://www.microsoft.com/downloads/details.aspx?familyid=32A63F52-9FE6-48E3-BB4E-7D4DDA5E0A90> Microsoft Internet Explorer 6 - Remote Code Execution - Critical - MS08-031
* Windows Server 2003 with SP1 for Itanium-based Systems and Windows
Server 2003 with SP2 for Itanium-based Systems -
<http://www.microsoft.com/downloads/details.aspx?familyid=1855997E-A3BE-46B1-A0BC-BB55EB0045FE> Microsoft Internet Explorer 6 - Remote Code Execution - Critical - MS08-031
* Internet Explorer 7
* Windows XP Service Pack 2 and Windows XP Service Pack 3 -
<http://www.microsoft.com/downloads/details.aspx?familyid=8E2125C7-52CB-4052-82A3-2D3C6A953752> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031
* Windows XP Professional x64 Edition and Windows XP Professional x64
Edition Service Pack 2 -
<http://www.microsoft.com/downloads/details.aspx?familyid=39B41E4B-3237-409D-A818-AB0517C5E7CF> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031
* Windows Server 2003 Service Pack 1 and Windows Server 2003 Service Pack
2 -
<http://www.microsoft.com/downloads/details.aspx?familyid=B3C2E2FD-1CB9-491B-937C-053DD59A65BF> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031
* Windows Server 2003 x64 Edition and Windows Server 2003 x64 Edition
Service Pack 2 -
<http://www.microsoft.com/downloads/details.aspx?familyid=88A26B76-F7DF-45C9-8ED0-7D3CD71C1987> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031
* Windows Server 2003 with SP1 for Itanium-based Systems and Windows
Server 2003 with SP2 for Itanium-based Systems -
<http://www.microsoft.com/downloads/details.aspx?familyid=97D0D37D-5D76-4BC3-8CBD-1E3976C82ACF> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031
* Windows Vista and Windows Vista Service Pack 1 -
<http://www.microsoft.com/downloads/details.aspx?familyid=13CBA012-DD20-48F9-8E44-E4CB104C4CAD> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031
* Windows Vista x64 Edition and Windows Vista x64 Edition Service Pack 1
-
<http://www.microsoft.com/downloads/details.aspx?familyid=EAD919C2-D548-47B7-9CD6-80F991266428> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031
* Windows Server 2008 for 32-bit Systems* -
<http://www.microsoft.com/downloads/details.aspx?familyid=4B52FF2F-D2F5-4C20-B6CF-86D86C56B0F8> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031
* Windows Server 2008 for x64-based Systems* -
<http://www.microsoft.com/downloads/details.aspx?familyid=DF9814A6-5BE0-4AC1-A767-A0EAE8D5EE5D> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031
* Windows Server 2008 for Itanium-based Systems -
<http://www.microsoft.com/downloads/details.aspx?familyid=FFC3CFCB-73FE-4A6D-9595-E9D7A5B3D3F7> Windows Internet Explorer 7 - Remote Code Execution - Critical - MS08-031

*Windows Server 2008 server core installation not affected. The
vulnerability addressed by this update does not affect supported editions
of Windows Server 2008 if Windows Server 2008 was installed using the
<http://msdn.microsoft.com/en-us/library/ms723891(VS.85).aspx> Server Core
installation option. For more information on this installation option, see
Server Core. Note that the Server Core installation option does not apply
to certain editions of Windows Server 2008; see
<http://www.microsoft.com/windowsserver2008/en/us/compare-core-installation.aspx> Compare Server Core Installation Options.

HTML Objects Memory Corruption Vulnerability - CVE-2008-2254
A remote code execution vulnerability exists in Internet Explorer due to
attempts to access uninitialized memory in certain situations. An attacker
could exploit the vulnerability by constructing a specially crafted Web
page. When a user views the Web page, the vulnerability could allow remote
code execution. An attacker who successfully exploited this vulnerability
could gain the same user rights as the logged-on user.

CVE Information:
<http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2254>
CVE-2008-2254.

HTML Objects Memory Corruption Vulnerability - CVE-2008-2255
A remote code execution vulnerability exists in Internet Explorer due to
attempts to access uninitialized memory in certain situations. An attacker
could exploit the vulnerability by constructing a specially crafted Web
page. When a user views the Web page, the vulnerability could allow remote
code execution. An attacker who successfully exploited this vulnerability
could gain the same user rights as the logged-on user.

CVE Information:
<http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2255>
CVE-2008-2255

Uninitialized Memory Corruption Vulnerability - CVE-2008-2256
A remote code execution vulnerability exists in the way Internet Explorer
accesses an object that has not been correctly initialized or that has
been deleted. An attacker could exploit the vulnerability by constructing
a specially crafted Web page. When a user views the Web page, the
vulnerability could allow remote code execution. An attacker who
successfully exploited this vulnerability could gain the same user rights
as the logged-on user.

CVE Information:
<http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2256>
CVE-2008-2256

HTML Objects Memory Corruption Vulnerability - CVE-2008-2257 and
CVE-2008-2258
A remote code execution vulnerability exists in Internet Explorer due to
attempts to access uninitialized memory in certain situations. An attacker
could exploit the vulnerability by constructing a specially crafted Web
page. When a user views the Web page, the vulnerability could allow remote
code execution. An attacker who successfully exploited this vulnerability
could gain the same user rights as the logged-on user.

CVE Information:
<http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2257>
CVE-2008-2257 and
<http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2258>
CVE-2008-2258

HTML Component Handling Vulnerability - CVE-2008-2259
A remote code execution vulnerability exists in the way Internet Explorer
handles argument validation in print preview handling. An attacker could
exploit the vulnerability by constructing a specially crafted Web page.
When a user views the Web page, the vulnerability could allow remote code
execution. An attacker who successfully exploited this vulnerability could
gain the same rights as the logged on user.

CVE Information:
<http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2259>
CVE-2008-2259


ADDITIONAL INFORMATION

The information has been provided by Microsoft Product Security.
The original article can be found at:
<http://www.microsoft.com/technet/security/bulletin/ms08-045.mspx>
http://www.microsoft.com/technet/security/bulletin/ms08-045.mspx



========================================


This bulletin is sent to members of the SecuriTeam mailing list.
To unsubscribe from the list, send mail with an empty subject line and body to: list-unsubscribe@xxxxxxxxxxxxxx
In order to subscribe to the mailing list, simply forward this email to: list-subscribe@xxxxxxxxxxxxxx


====================
====================

DISCLAIMER:
The information in this bulletin is provided "AS IS" without warranty of any kind.
In no event shall we be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages.