[UNIX] Novell SUSE Linux Enterprise Server Remote Manager Heap Overflow



The following security advisory is sent to the securiteam mailing list, and can be found at the SecuriTeam web site: http://www.securiteam.com
- - promotion

The SecuriTeam alerts list - Free, Accurate, Independent.

Get your security news from a reliable source.
http://www.securiteam.com/mailinglist.html

- - - - - - - - -



Novell SUSE Linux Enterprise Server Remote Manager Heap Overflow
------------------------------------------------------------------------


SUMMARY

Novell Open Enterprise Server is "a secure, highly available suite of
services that provides proven networking, communication, collaboration and
application services in an open, easy-to-deploy environment".

Improper input validation allows attackers to cause a buffer overflow and
execute arbitrary code on Novell SuSE Linux.

DETAILS

Vulnerable Systems:
* Novell SUSE Linux Enterprise Server 9

The vulnerability specifically exists due to improper handling of a an
HTTP POST request with a negative Content-Length parameter. When such a
request is received, controllable heap corruption occurs which can lead to
the execution of arbitrary code using traditional Linux heap overflow
methods. The following HTTP request can be used to trigger this
vulnerability.

POST / HTTP/1.0
Content-Length: -900

DATA_THAT_WILL_BE_USED_TO_OVERWRITE_THE_HEAP

With careful manipulation of the string, an arbitrary 4 byte write may be
achieved which can be used to gain execution control and execute arbitrary
code.

CVE Information:
<http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3655>
CVE-2005-3655

Disclosure Timeline:
11/15/2005 - Initial vendor notification
11/15/2005 - Initial vendor response
01/13/2006 - Coordinated public disclosure


ADDITIONAL INFORMATION

The information has been provided by
<mailto:idlabs-advisories@xxxxxxxxxxxxxxxxxx> iDEFENSE Labs .
The original article can be found at:
<http://www.idefense.com/application/poi/display?type=vulnerabilities>
http://www.idefense.com/application/poi/display?type=vulnerabilities



========================================


This bulletin is sent to members of the SecuriTeam mailing list.
To unsubscribe from the list, send mail with an empty subject line and body to: list-unsubscribe@xxxxxxxxxxxxxx
In order to subscribe to the mailing list, simply forward this email to: list-subscribe@xxxxxxxxxxxxxx


====================
====================

DISCLAIMER:
The information in this bulletin is provided "AS IS" without warranty of any kind.
In no event shall we be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages.



Relevant Pages

  • [EXPL] AJ Web Server Buffer Overflow DoS
    ... The following security advisory is sent to the securiteam mailing list, and can be found at the SecuriTeam web site: http://www.securiteam.com ... AJ Web Server is "an Visual Basic open ... Flaws in the way HTTP request are handled by Aj Server makes it vulnerable ... to a denial of service vulnerability whenever it tries to handle a long ...
    (Securiteam)
  • [NT] Multiple Vulnerabilities in Video Cam Server
    ... The following security advisory is sent to the securiteam mailing list, and can be found at the SecuriTeam web site: http://www.securiteam.com ... The Video Cam Server product has been found to contain multiple ... The a vulnerability in the remote web server allows a user to discover the ... characters with the request sent to the server. ...
    (Securiteam)
  • [EXPL] phpBB UID Exploit (Perl Exploit 2)
    ... The following security advisory is sent to the securiteam mailing list, and can be found at the SecuriTeam web site: http://www.securiteam.com ... This exploit modifies the UID field in the cookies sent back to the phpBB ... my $request = "http://"; ... More exploits for the phpBB UID vulnerability can be found: ...
    (Securiteam)
  • [UNIX] Trend Micro VirusWall Buffer Overflow in VSAPI Library
    ... The following security advisory is sent to the securiteam mailing list, and can be found at the SecuriTeam web site: http://www.securiteam.com ... buffer overflow vulnerability in VSAPI library allows arbitrary code ... is called "vscan" which is set suid root by default. ... permissions and thus granted all local users the privilege to execute the ...
    (Securiteam)
  • [UNIX] SCO Multiple Local Buffer Overflow
    ... The following security advisory is sent to the securiteam mailing list, and can be found at the SecuriTeam web site: http://www.securiteam.com ... Local exploitation of a buffer overflow vulnerability in the ppp binary, ... allows attackers to gain root privileges. ...
    (Securiteam)