[Full-disclosure] [SECURITY] [DSA 2488-1] iceweasel security update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2488-1 security@xxxxxxxxxx
http://www.debian.org/security/ Thijs Kinkhorst
June 7, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : iceweasel
Vulnerability : several vulnerabilities
Problem type : local (remote)
Debian-specific: no
CVE ID : CVE-2012-1937 CVE-2012-1940 CVE-2012-1947

Several vulnerabilities have been discovered in Iceweasel, a web
browser based on Firefox. The included XULRunner library provides
rendering services for several other applications included in Debian.

CVE-2012-1937

Mozilla developers discovered several memory corruption bugs,
which may lead to the execution of arbitrary code.

CVE-2012-1940

Abhishek Arya discovered a use-after-free problem when working
with column layout with absolute positioning in a container that
changes size, which may lead to the execution of arbitrary code.

CVE-2012-1947

Abhishek Arya discovered a heap buffer overflow in utf16 to latin1
character set conersion, allowing to execute arbitray code.


Note: We'd like to advise users of Iceweasel's 3.5 branch in Debian
stable to consider to upgrade to the Iceweasel 10.0 ESR (Extended
Support Release) which is now availble in Debian Backports.
Although Debian will continue to support Iceweasel 3.5 in stable with
security updates, this can only be done on a best effort base as
upstream provides no such support anymore. On top of that, the 10.0
branch adds proactive security features to the browser.

For the stable distribution (squeeze), this problem has been fixed in
version 3.5.16-16.

For the unstable distribution (sid), this problem has been fixed in
version 10.0.5esr-1.

We recommend that you upgrade your iceweasel packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@xxxxxxxxxxxxxxxx
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQEcBAEBAgAGBQJP0Q4zAAoJEOxfUAG2iX57F8gH/2EqfcbufbUCEjdSHL1gXfpF
asE/BVla9JYI+nKZJLYqqgWmnArl3Y2bHSrYHFgn/ZHqcFS+r1Unc1eMZptCnDav
Ek072tNM75FtH6pfc/5Aw0ZTl4M6kW7jDSEcgqJ2JkmPHjfAY17k9kMWyoUzVoNj
PBl+CmoRx8Cs23ZVgSDcH+9zQs38z+6PQF6vn+5VorDeQBX6ecIPlqKmg74qFXUU
wV7SJk1Nj9jOPaQ/6MokK4BZ1LddiX1tjCHzRKOzpRFGSN+HEoGPD7JWmpJC7Dtq
n8PXrSdub3LqtI1zWsSc+81EGuw9eTZENvVsEyIUCEG271IaGz7YhJgkvA7OtJw=
=XJbq
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/



Relevant Pages

  • [Full-disclosure] [SECURITY] [DSA 2553-1] iceweasel security update
    ... rendering services for several other applications included in Debian. ... The reported vulnerabilities could lead to the execution of arbitrary ... For the stable distribution, these problems have been fixed in ... We recommend that you upgrade your iceweasel packages. ...
    (Full-Disclosure)
  • Re: Instability in Iceweasel
    ... I really wish they would break one browser at a time. ... And now they've broken iceweasel too. ... I previously posted a message about iceweasel destroying my Debian ... different Debian installation, to which I now have to telnet, using ...
    (Debian-User)
  • [Full-disclosure] [SECURITY] [DSA 2313-1] iceweasel security update
    ... Vulnerability: several ... For the stable distribution, ... We recommend that you upgrade your iceweasel packages. ... Further information about Debian Security Advisories, ...
    (Full-Disclosure)
  • [SECURITY] [DSA 2313-1] iceweasel security update
    ... Vulnerability: several ... For the stable distribution, ... We recommend that you upgrade your iceweasel packages. ... Further information about Debian Security Advisories, ...
    (Bugtraq)
  • [SECURITY] [DSA 2488-1] iceweasel security update
    ... Several vulnerabilities have been discovered in Iceweasel, ... We'd like to advise users of Iceweasel's 3.5 branch in Debian ... branch adds proactive security features to the browser. ...
    (Bugtraq)