[Full-disclosure] [SECURITY] [DSA 2403-1] php5 security update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2403-1 security@xxxxxxxxxx
http://www.debian.org/security/ Thijs Kinkhorst
February 02, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : php5
Vulnerability : code injection
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-0830

Stefan Esser discovered that the implementation of the max_input_vars
configuration variable in a recent PHP security update was flawed such
that it allows remote attackers to crash PHP or potentially execute
code.

For the oldstable distribution (lenny), no fix is available at this time.

For the stable distribution (squeeze), this problem has been fixed in
version 5.3.3-7+squeeze7.

The testing distribution (wheezy) and unstable distribution (sid)
will be fixed soon.

We recommend that you upgrade your php5 packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@xxxxxxxxxxxxxxxx
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQEcBAEBAgAGBQJPKv//AAoJEOxfUAG2iX57gpEIANgTI7dZgT2Pdf7ajBy3fFVX
uGSwFoGe9lFVpF2i3tlvB/riN1wlvn6Q13lLjR257DQk0lwi0vwJWFmfITG6CGMS
ARNVdHVBMAZpoyiAsQDdYid7FPJQONxGaubEO9MMGgnBYkMtea7jXtJqrkTCcvvg
4qccjxnd5VhQ6d2prPqbqjvouC7E3oxLPtw0quc6tzXjVvP0cAD0dICtJHZpgzNb
IjyEWpds5GV+hvPoqa57lqC0BjeUrFQCKJvbwWOAPJvSfE4jn0KE3+LwwS+znSs4
VvHjsASRw7h0e8vhlrph8dWFeD9Qc8sNInMaf8PvS7CkGrJ7xenEnWnbkUNzXc8=
=2Af1
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/



Relevant Pages

  • [SECURITY] [DSA 2403-1] php5 security update
    ... Problem type: remote ... configuration variable in a recent PHP security update was flawed such ... For the oldstable distribution, no fix is available at this time. ... Further information about Debian Security Advisories, ...
    (Bugtraq)
  • [Full-disclosure] [SECURITY] [DSA 2403-2] php5 security update
    ... Vulnerability: code injection ... Problem type: remote ... configuration variable in a recent PHP security update was flawed such ... Further information about Debian Security Advisories, ...
    (Full-Disclosure)
  • [Full-disclosure] [SECURITY] [DSA 2391-1] phpmyadmin security update
    ... Several vulnerabilities have been discovered in phpMyAdmin, ... The XML import plugin allowed a remote attacker to read arbitrary ... The oldstable distribution is not affected by these problems. ... Further information about Debian Security Advisories, ...
    (Full-Disclosure)
  • [SECURITY] [DSA 2403-2] php5 security update
    ... Vulnerability: code injection ... Problem type: remote ... configuration variable in a recent PHP security update was flawed such ... Further information about Debian Security Advisories, ...
    (Bugtraq)
  • [Full-disclosure] [SECURITY] [DSA 2515-1] nsd3 security update
    ... Vulnerability: null pointer dereference ... Problem type: remote ... For the testing distribution, this problem will be fixed soon. ... Further information about Debian Security Advisories, ...
    (Full-Disclosure)