[Full-disclosure] [ MDVSA-2009:166 ] c-client




-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2009:166
http://www.mandriva.com/security/
_______________________________________________________________________

Package : c-client
Date : July 28, 2009
Affected: Enterprise Server 5.0
_______________________________________________________________________

Problem Description:

Security vulnerabilities has been identified and fixed in University
of Washington IMAP Toolkit:

Multiple stack-based buffer overflows in (1) University of Washington
IMAP Toolkit 2002 through 2007c, (2) University of Washington Alpine
2.00 and earlier, and (3) Panda IMAP allow (a) local users to gain
privileges by specifying a long folder extension argument on the
command line to the tmail or dmail program; and (b) remote attackers to
execute arbitrary code by sending e-mail to a destination mailbox name
composed of a username and '+' character followed by a long string,
processed by the tmail or possibly dmail program (CVE-2008-5005).

smtp.c in the c-client library in University of Washington IMAP Toolkit
2007b allows remote SMTP servers to cause a denial of service (NULL
pointer dereference and application crash) by responding to the QUIT
command with a close of the TCP connection instead of the expected
221 response code (CVE-2008-5006).

Off-by-one error in the rfc822_output_char function in the RFC822BUFFER
routines in the University of Washington (UW) c-client library, as
used by the UW IMAP toolkit before imap-2007e and other applications,
allows context-dependent attackers to cause a denial of service (crash)
via an e-mail message that triggers a buffer overflow (CVE-2008-5514).

The updated packages have been patched to prevent this. Note that the
software was renamed to c-client starting from Mandriva Linux 2009.0
and only provides the shared c-client library for the imap functions
in PHP.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5005
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5006
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5514
_______________________________________________________________________

Updated Packages:

Mandriva Enterprise Server 5:
979adacd7e64de937ce07b5b90b57c3f mes5/i586/libc-client0-2007b-1.2mdvmes5.i586.rpm
3e60e9d361863d0879794275e55c5417 mes5/i586/libc-client-devel-2007b-1.2mdvmes5.i586.rpm
a807b7aaeb0f63ef6ea7f8a5e883b4a2 mes5/SRPMS/c-client-2007b-1.2mdvmes5.src.rpm

Mandriva Enterprise Server 5/X86_64:
5a1ab0125c5a96e1242c92ac4b59f593 mes5/x86_64/lib64c-client0-2007b-1.2mdvmes5.x86_64.rpm
f4394a067b2d10f0a30a8ae7f7fdcf33 mes5/x86_64/lib64c-client-devel-2007b-1.2mdvmes5.x86_64.rpm
a807b7aaeb0f63ef6ea7f8a5e883b4a2 mes5/SRPMS/c-client-2007b-1.2mdvmes5.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFKbzc4mqjQ0CJFipgRAj3+AJ9g1TpKpkIxn2o3zNOs6A05QDQoCQCgtFrV
IWkC8GlTdfdmoD134o/84Dc=
=pY+q
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/



Relevant Pages

  • [Full-disclosure] [ MDVSA-2009:163 ] tomcat5
    ... Affected: Enterprise Server 5.0 ... The updated packages have been patched to prevent this. ... Mandriva Enterprise Server 5/X86_64: ... All packages are signed by Mandriva for security. ...
    (Full-Disclosure)
  • [ MDVSA-2009:163 ] tomcat5
    ... Affected: Enterprise Server 5.0 ... The updated packages have been patched to prevent this. ... Mandriva Enterprise Server 5/X86_64: ... All packages are signed by Mandriva for security. ...
    (Bugtraq)
  • [Full-disclosure] [ MDVSA-2009:198 ] firefox
    ... 2009.0, 2009.1, Enterprise Server 5.0 ... Security researcher Juan Pablo Lopez Yacubian reported that an attacker ... Updated Packages: ... Mandriva Linux 2009.0/X86_64: ...
    (Full-Disclosure)
  • [ MDVSA-2009:166 ] c-client
    ... Affected: Enterprise Server 5.0 ... Security vulnerabilities has been identified and fixed in University ... smtp.c in the c-client library in University of Washington IMAP Toolkit ... Mandriva Enterprise Server 5: ...
    (Bugtraq)