[Full-disclosure] rPSA-2007-0199-1 openssl openssl-scripts



rPath Security Advisory: 2007-0199-1
Published: 2007-09-25
Products: rPath Linux 1
Rating: Major
Exposure Level Classification:
Remote Deterministic Unauthorized Access
Updated Versions:
openssl=/conary.rpath.com@rpl:devel//1-compat/0.9.7a-0.1-1
openssl-scripts=/conary.rpath.com@rpl:devel//1-compat/0.9.7a-0.1-1

rPath Issue Tracking System:
https://issues.rpath.com/browse/RPL-1633
https://issues.rpath.com/browse/RPL-1613
https://issues.rpath.com/browse/RPL-616
https://issues.rpath.com/browse/RPL-613

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2969
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2940
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4339
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3108

Description:
The previous version of the legacy openssl compatibility package
may enable vulnerabilities to multiple attacks in applications that
use this library, some of which which may allow a remote attacker
Unauthorized Access. Other vulnerabilities include Denials of
Service and Information Exposure.

This compatibility library was provided solely for transient
compatibility with applications built for alpha releases of rPath
Linux, to make it easier for alpha testers to upgrade their systems
to rPath Linux 1. rPath is not aware of any applications that
currently use these libraries, and so it is unlikely that any
systems will actually be vulnerable to these attacks.

Copyright 2007 rPath, Inc.
This file is distributed under the terms of the MIT License.
A copy is available at http://www.rpath.com/permanent/mit-license.html

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/



Relevant Pages