[Full-disclosure] rPSA-2007-0183-1 lighttpd



rPath Security Advisory: 2007-0183-1
Published: 2007-09-14
Products: rPath Linux 1
Rating: Severe
Exposure Level Classification:
Remote System User Deterministic Unauthorized Access
Updated Versions:
lighttpd=/conary.rpath.com@rpl:devel//1/1.4.18-0.1-1

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4727
https://issues.rpath.com/browse/RPL-1715

Description:
Previous versions of the lighttpd package are vulnerable to a remote
Arbitrary Code Execution attack due to a header overflow in the
mod_fastcgi extension.

lighttpd is not installed by default on rPath Linux systems; only
systems customized to include lighttpd and enable mod_fastcgi are
vulnerable.

Note that the rPath Appliance Platform Agent (rAPA) does not enable
the mod_fastcgi extension, and so is not vulnerable to this attack.

Copyright 2007 rPath, Inc.
This file is distributed under the terms of the MIT License.
A copy is available at http://www.rpath.com/permanent/mit-license.html

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/