[Full-disclosure] [ GLSA 200704-13 ] File: Denial of Service



- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200704-13
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: File: Denial of Service
Date: April 17, 2007
Bugs: #174217
ID: 200704-13

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability has been discovered in file allowing for a denial of
service.

Background
==========

file is a utility that identifies a file format by scanning binary data
for patterns.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-apps/file == 4.20 >= 4.20-r1

Description
===========

Conor Edberg discovered an error in the way file processes a specific
regular expression.

Impact
======

A remote attacker could entice a user to open a specially crafted file,
using excessive CPU ressources and possibly leading to a Denial of
Service. Note that this vulnerability could be also triggered through
an automatic file scanner like amavisd-new.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All file users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-apps/file-4.20-r1"

References
==========

[ 1 ] CVE-2007-2026
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2026

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200704-13.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: pgpC5xABpLKvE.pgp
Description: PGP signature

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

Relevant Pages

  • [Full-Disclosure] Re: its all about timing
    ... >hunters, sure don't sound like they need some else telling them what ... I think it's because there are more "consumers" of vulnerability ... to remove those bugs from their vulnerable systems. ... responsible for the security of large, ...
    (Full-Disclosure)
  • [ GLSA 200704-13 ] File: Denial of Service
    ... Bugs: #174217 ... Note that this vulnerability could be also triggered through ... Security is a primary focus of Gentoo Linux and ensuring the ...
    (Bugtraq)
  • Re: starwreck
    ... crack attempts -- pull services are only vulnerable to attacks transmitted ... assuming it has bugs that open security flaws. ... automatic vulnerability -- there really do have bugs for there to be a ...
    (rec.music.filk)
  • [Full-disclosure] [ GLSA 200908-07 ] Perl Compress::Raw modules: Denial of Service
    ... Bugs: #273141, #281955 ... affected packages on all of their supported architectures. ... Security is a primary focus of Gentoo Linux and ensuring the ...
    (Full-Disclosure)
  • [Full-disclosure] [ GLSA 200710-07 ] Tk: Buffer overflow
    ... Bugs: #192539 ... A buffer overflow vulnerability has been discovered in Tk. ... Security is a primary focus of Gentoo Linux and ensuring the ...
    (Full-Disclosure)