[Full-disclosure] [ GLSA 200704-12 ] OpenOffice.org: Multiple vulnerabilities



- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200704-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: OpenOffice.org: Multiple vulnerabilities
Date: April 16, 2007
Bugs: #170828
ID: 200704-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in OpenOffice.org,
allowing for remote execution of arbitrary code.

Background
==========

OpenOffice.org is an open source office productivity suite, including
word processing, spreadsheet, presentation, drawing, data charting,
formula editing, and file conversion facilities.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-office/openoffice < 2.1.0-r1 >= 2.1.0-r1
2 app-office/openoffice-bin < 2.2.0 >= 2.2.0
-------------------------------------------------------------------
2 affected packages on all of their supported architectures.
-------------------------------------------------------------------

Description
===========

John Heasman of NGSSoftware has discovered a stack-based buffer
overflow in the StarCalc parser and an input validation error when
processing metacharacters in a link. Also OpenOffice.Org includes code
from libwpd making it vulnerable to heap-based overflows when
converting WordPerfect document tables (GLSA 200704-07).

Impact
======

A remote attacker could entice a user to open a specially crafted
document, possibly leading to execution of arbitrary code with the
rights of the user running OpenOffice.org.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All OpenOffice.org users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-office/openoffice-2.1.0-r1"

All OpenOffice.org binary users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-office/openoffice-bin-2.2.0"

References
==========

[ 1 ] CVE-2007-0002
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0002
[ 2 ] CVE-2007-0238
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0238
[ 3 ] CVE-2007-0239
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0239
[ 4 ] GLSA-200704-07
http://www.gentoo.org/security/en/glsa/glsa-200704-07.xml

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200704-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: pgpuWUp7Q0i1d.pgp
Description: PGP signature

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

Relevant Pages